Project

General

Profile

Bug #4050

[Regression] Bound weapons no longer equip on conjure

Added by Hristos Triantafillou about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
-
Start date:
08/31/2017
% Done:

0%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

I believe this commit (https://github.com/OpenMW/openmw/pull/1405) has introduced a regression where a bound weapon doesn't equip when conjured.

When I cast "Bound Longsword" I expect that once the spell is cast, the bound sword is equipped.

What happens now is I get a pop-up message saying I need to finish my current action, and the sword is not equipped but placed into my inventory.

This was tested on dc53573de44cf3c858f01280cc4a25261cebd9a1.

Associated revisions

Revision 0d7279ea (diff)
Added by Andrei Kortunov about 2 months ago

Fixes a regression with bound weapons equipping (bug #4050)

History

#1 Updated by Alexei Dobrohotov about 2 months ago

  • Subject changed from Bound weapons no longer equip on conjure to [Regression] Bound weapons no longer equip on conjure
  • Category set to Game Mechanics
  • Status changed from New to Confirmed
  • Operating system changed from Linux to Other

Can reproduce.

#2 Updated by Andrei Kortunov about 2 months ago

In Morrowind PC equips bound weapon after end of casting animation, in OpenMW - during casting animation. Such difference causes this issue.

#3 Updated by Andrei Kortunov about 2 months ago

I'll fix this regression if we will decide to leave https://github.com/OpenMW/openmw/pull/1405.

#4 Updated by Alexei Dobrohotov about 2 months ago

"Leave" as in "keep"?

#5 Updated by Andrei Kortunov about 2 months ago

"Leave" as in "keep"?

Yes. Sorry, my English is bad.

#6 Updated by Chris Robinson about 2 months ago

I think that pull request should stay, since we don't want to be able to switch on a whim. But it can certainly do with improvements, like having weapon swaps from Bound spells occur when the animation is done, or being able to unready a weapon before the attack button has been released.

#7 Updated by Dark Locq about 2 months ago

See also #4051, #4053; different effects of the same change.

#8 Updated by Dark Locq about 2 months ago

Ultimately this traces back to #2445.

#9 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov

#10 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF