Project

General

Profile

Bug #3833

[Mod] Windows Glow: windows textures are much darker than in original game

Added by Andrei Kortunov 5 months ago. Updated 9 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
NIF format
Target version:
Start date:
04/19/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

This mod mostly works fine, but windows are much darker than in Morrowind.

See this forum thread: https://forum.openmw.org/viewtopic.php?f=40&t=3906

OpenMW version: current master (df3b4fe6a5df8185566fdfa8d931c4ed6ce8aa4a).

Associated revisions

Revision bc82c6a3 (diff)
Added by scrawl . 23 days ago

Use white color if told to use nonexisting vertexcolors (Fixes #3833)

History

#1 Updated by scrawl . 5 months ago

If I remember correctly (there's another issue that I can't find) the mod replaces an object ID with another object of a different type (e.g. static replaced by activator), which we don't currently support.

#2 Updated by Alexei Dobrohotov 5 months ago

#3085, right?

#3 Updated by Andrei Kortunov 5 months ago

Yes, statics are replaced by activators (IDs are different).
For example:
ex_vivec_c_02 - original removed static
wx_vivec_c_02 - daytime activator
wx_vivec_c_02_m - night time activator

Scripting day/night switch works fine, just no glow effect on night windows. Maybe OpenMW does not support NIF-property needed for this effect.

#4 Updated by Alexei Dobrohotov 5 months ago

No, no, glowmaps are actually supported.

#5 Updated by Amenophis . 5 months ago

Look my report here. Maybe the statics are overlapping and creating that darker version.
http://bugs.openmw.org/issues/2213

#6 Updated by scrawl . 5 months ago

#3085, right?

Yes, that. I forgot that is solved already.

In this case, the problem are the unimplemented fields Vertex Mode and Lighting Mode in NiVertexColorProperty (example ex_common_window_01.nif). Remove that property and the glow disappears.

I don't know what these fields are supposed to do exactly.

#7 Updated by scrawl . 26 days ago

I don't know what these [ Vertex Mode and Lighting Mode ] fields are supposed to do exactly.

If anyone wants to have a go at this, I'd suggest capturing an apitrace of MW in Wine, using a minimal scene to test different Vertex Mode / Lighting Mode values so we can see the OpenGL modes these map to.

#8 Updated by scrawl . 23 days ago

  • Status changed from New to Closed
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

Plz post a mod link next time, I just wasted 30 mins trying to find this version which couldn't be found I ended up using abot's version instead which appears to have a similar nif file.

apitrace did not turn out to be helpful. The only change to be seen is a different ARB program object being used. I don't know if program objects are just the result of WINE or if the game actually uses them. In the former case running apitrace over D3D might work better.

Experimentally, I determined that VertMode controls which colors are set to the vertex color, and LightMode controls which colors will be used for the lighting equation. LightMode does seem kinda redundant since we could just as well set the colors we don't want to use to zero.

LightMode and VertMode have now been implemented in 5d2fe5e887b10ca84f645af42008723777b1e31a, but on its own do not fix the windows glow issue. There was another difference in behavior: when a material attempts to use vertex color tracking, but there aren't vertex colors to use, OpenMW would ignore this request, but the original engine apparently will use a default color (1 1 1) in place of the vertex color. (In this case as the emissive color, producing the glow). Fixed as bc82c6a35da5c6d46581b91afcfb5300fd360b53

#9 Updated by Alexei Dobrohotov 9 days ago

  • Category set to NIF format
  • Assignee set to scrawl .

Also available in: Atom PDF