Project

General

Profile

Bug #3343

OpenMW-CS: ID sorting is case-sensitive in certain tables

Added by *pi03k * about 2 years ago. Updated 14 days ago.

Status:
Closed
Priority:
Low
Category:
Editor
Target version:
Start date:
04/11/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

In Objects table sorting by ID is case insensitive (proper IMHO). On the other hand in Verification results sorting by ID puts upper case Z before lower case a.

History

#1 Updated by *pi03k * about 2 years ago

  • Subject changed from Inconsistent column sorting to Editor: Inconsistent column sorting

#2 Updated by Marc Zinnschlag about 2 years ago

  • Target version set to openmw-0.40

#3 Updated by *pi03k * about 2 years ago

  • Assignee set to *pi03k *

#4 Updated by Marc Zinnschlag almost 2 years ago

  • Target version changed from openmw-0.40 to openmw-cs-1.0

#5 Updated by Jeffrey Haines over 1 year ago

  • Subject changed from Editor: Inconsistent column sorting to OpenMW-CS: Inconsistent column sorting

Unify all editor ticket subjects to start with "OpenMW-CS:"

#6 Updated by Martin Otto over 1 year ago

Again, @*pi03k *: Are you still working on that issue? If not, do you mind deassign yourself from it?

#7 Updated by *pi03k * about 1 year ago

Martin Otto wrote:

Again, @*pi03k *: Are you still working on that issue? If not, do you mind deassign yourself from it?

Sure, take it.

#8 Updated by *pi03k * about 1 year ago

  • Assignee deleted (*pi03k *)

#9 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from New to Confirmed
  • Operating system changed from Linux to Other

#10 Updated by Alexei Dobrohotov about 2 months ago

  • Subject changed from OpenMW-CS: Inconsistent column sorting to OpenMW-CS: ID sorting is case-sensitive in certain tables

This also affects search results sorting.

#11 Updated by Alf Henrik Sauge 15 days ago

It's been a while since I've worked with Qt, but I believe I've got a proper fix for the Verfication Results view. Now I'm wonder, are there any other tables that aren't sorted correctly? As far as I can tell, it's the odd one out and I can't find any other tables with the same issue.

#12 Updated by Alexei Dobrohotov 15 days ago

Cool.
This affects all "report tables", I think. Verification results table is one, and search results table is also one.

#13 Updated by Alexei Dobrohotov 14 days ago

  • Status changed from Confirmed to Resolved
  • Target version changed from openmw-cs-1.0 to openmw-0.44
  • % Done changed from 0 to 100

#14 Updated by Marc Zinnschlag 14 days ago

  • Status changed from Resolved to Closed
  • Assignee set to Alf Henrik Sauge

Also available in: Atom PDF