Project

General

Profile

Feature #2042

Adding a non-portable Light to the inventory should cause the player to glow

Added by Stuart Moore over 2 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
10/21/2014
% Done:

100%

Severity:
Normal

Description

Was selling Nalcarya some stuff, when I'd finished I noticed a blank spot in the player inventory. Clicked around on that spot, and a key (I was carrying) appeared there. Then the lighting for the entire cell (still in the shop) turned a weird shade of yellow. Outside seems normal enough and no other interior cell appears to have been affected, either.

https://dl.dropboxusercontent.com/u/67740160/ThisIsNotTheLightingColourThisCellIsSupposedToHave.jpg is a screenshot.

https://dl.dropboxusercontent.com/u/67740160/_BUG__Nalcarya_s_shop_is_yellow_tinged_ is a savegame with the issue.


Related issues

Related to OpenMW - Bug #2069: [Mod: Fireflies Invade Morrowind]: A couple of issues Confirmed 10/27/2014
Related to OpenMW - Feature #3338: Make Non-Portable Lights within creatures and containers keep shining after reload. Closed 04/10/2016

Associated revisions

Revision 11565b59
Added by Miroslav Remák 4 months ago

Make actors with non-portable lights in inventory glow (Closes #2042, #3338)

History

#1 Updated by Stuart Moore over 2 years ago

No issues had shown up on the command line while running OpenMW, by the way.

Revision 5fdd264d07

#2 Updated by Jannik Heller over 2 years ago

Light is caused by a reference "yellow light" that has been dropped there. I presume you got this into your inventory somehow, since it's not meant to be there it has no icon and shows up blank. Then you dropped it into the cell without noticing.
So, the real question is, how did it get into your inventory? I checked the default 3 ESMs for occurrences of this reference and there are none, not even in scripts. I think it might a mod that you're using.

#3 Updated by Thomas Staudinger over 2 years ago

Oh yeah, we already had that problem, can happen with vanilla assets too, but you have to use the console to give yourself some unusual (normally not usable) object, e.g. some static lanterns, then there will be a blank spot in your inventory which corresponds to that object, when I reported that a while back someone (scrawl?) said they want to keep that as it is (to allow for certain kinds of mods if I remember correctly).

You can try it by writing "player->additem light_de_paper_lantern_01_200 1" in the console, this will give you such a blank spot, if you put that invisible item on the ground it will be visible as a lantern that is not able to be picked up.

#4 Updated by Thomas Staudinger over 2 years ago

Oh yeah, in vanilla, if you add that item to your PC, nothing will be in your inventory, but you will start to glow ;)

#5 Updated by Thomas Staudinger over 2 years ago

edit: By vanilla I mean the original Morrowind

#6 Updated by Thomas Staudinger over 2 years ago

edit2: That was the earlier bug report: #1044

#7 Updated by Jannik Heller almost 2 years ago

  • Subject changed from Odd lighting issue, triggered by selling things(?) and/or inventory spacing issues(?). to Adding a non-portable Light to the inventory should cause the player to glow

#8 Updated by Jannik Heller almost 2 years ago

  • Tracker changed from Bug to Feature
  • Target version set to openmw-0.41

As it turns out, this is used in the vanilla game files, in particular the "Hopesfire" blade which should emit light but does not in OpenMW.


if ( bladeOut == 0 )
    if ( Player->GetItemCount "Blade Light" > 0 )
        Player->RemoveItem "Blade Light" 1
        set addOnce to 0
    endif
endif

if ( bladeOut == 1 )
    if ( addOnce == 0 )
        Player->AddItem "Blade Light" 1
        set addOnce to 1
    endif
endif

#9 Updated by Jannik Heller almost 2 years ago

Correction: the Trueflame blade (nerevarblade_01_flame), not Hopesfire.

#10 Updated by Jannik Heller over 1 year ago

  • Related to Bug #2069: [Mod: Fireflies Invade Morrowind]: A couple of issues added

#11 Updated by Jannik Heller 10 months ago

  • Related to Feature #3338: Make Non-Portable Lights within creatures and containers keep shining after reload. added

#12 Updated by Miroslav Remák 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Miroslav Remák

#13 Updated by Miroslav Remák 4 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF