Project

General

Profile

Feature #824

Fading for doors and teleport commands

Added by Manuel Edelmann over 4 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Rendering
Target version:
Start date:
06/19/2013
% Done:

100%

Severity:
Normal

Description

In MW, the game will fade to black before changing cells (except Exterior->Exterior transitions). OpenMW doesn't do it yet.

History

#1 Updated by Manuel Edelmann over 4 years ago

Exterior->Interior transitions are implemented. I don't know how to handle interior->exterior transitions yet.

#2 Updated by Lars Söderberg over 3 years ago

  • Target version set to openmw-0.31

#3 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.31 to openmw-0.32

#4 Updated by Marc Zinnschlag over 3 years ago

  • Tracker changed from Task to Feature
  • Category set to Rendering

#5 Updated by Miroslav Remák over 3 years ago

Is this really a thing in vanilla? In my quick test it only seems to happen with the guild guides, otherwise there is no fade effect, even if the destination cell must be loaded.

#6 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.32 to openmw-0.33

#7 Updated by Marc Zinnschlag about 3 years ago

  • Target version changed from openmw-0.33 to openmw-0.34

#8 Updated by Thomas Staudinger about 3 years ago

Vanilla Morrowind also fades to black after loading when starting a new game.

#9 Updated by Marc Zinnschlag about 3 years ago

  • Target version changed from openmw-0.34 to openmw-0.35

#10 Updated by Marc Zinnschlag almost 3 years ago

  • Target version changed from openmw-0.35 to openmw-0.35.1

#11 Updated by Marc Zinnschlag almost 3 years ago

  • Target version changed from openmw-0.35.1 to openmw-0.36

#12 Updated by Marc Zinnschlag over 2 years ago

  • Target version changed from openmw-0.36 to openmw-0.37

#13 Updated by Marc Zinnschlag about 2 years ago

  • Target version changed from openmw-0.37 to openmw-0.38

#14 Updated by scrawl . almost 2 years ago

Is this really a thing in vanilla? In my quick test it only seems to happen with the guild guides, otherwise there is no fade effect, even if the destination cell must be loaded.

I can't confirm that either.

Vanilla Morrowind also fades to black after loading when starting a new game.

This seems to be the only thing we're missing.

#15 Updated by Manuel Edelmann almost 2 years ago

Jannik Heller wrote:

Is this really a thing in vanilla? In my quick test it only seems to happen with the guild guides, otherwise there is no fade effect, even if the destination cell must be loaded.

I can't confirm that either.

Vanilla Morrowind also fades to black after loading when starting a new game.

This seems to be the only thing we're missing.

After testing it again, vanilla MW does indeed fade to black after using doors.

Try this: Start a new game. Use the console command: coc "Balmora, Guild of Mages" and use the door exit the guild. It will fade to black until the exterior cell is loaded, vice versa.

#16 Updated by scrawl . almost 2 years ago

Try this: Start a new game. Use the console command: coc "Balmora, Guild of Mages" and use the door exit the guild. It will fade to black until the exterior cell is loaded, vice versa.

Hm, yes, if you just started a new game the fading works. Then try saving and reloading the game -> the fade effect no longer appears from that point on.

#17 Updated by Miroslav Remák almost 2 years ago

Seems like yet another feature that is broken in vanilla. From my observations, if the first thing you do after running MW is load a game, the fade effect will be off until you load a game again/start a new game, which will toggle it on.

On top of that, you can toggle the effect on/off manually via the ToggleLoadFade (TLF) command.

Jannik Heller wrote:

Hm, yes, if you just started a new game the fading works. Then try saving and reloading the game -> the fade effect no longer appears from that point on.

Weird, the fade effect still appears if I do that. Unless by reloading the game you mean restarting MW and then loading that savegame...

#18 Updated by Marc Zinnschlag almost 2 years ago

  • Target version changed from openmw-0.38 to openmw-0.39

#19 Updated by Marc Zinnschlag over 1 year ago

  • Target version changed from openmw-0.39 to openmw-0.40

#20 Updated by Marc Zinnschlag over 1 year ago

  • Target version changed from openmw-0.40 to openmw-0.41

#21 Updated by August Avatar over 1 year ago

Thank you Miroslav, this feature of vanilla had puzzled me for ages. Perhaps this can be a toggle option in settings.cfg when it is implemented, along with the TLF console command. That way we can have cell transitions working both the way it was seemingly intended to by the developers, along with the behavior most players are probably used to.

#22 Updated by Miroslav Remák over 1 year ago

August Avatar wrote:

Thank you Miroslav, this feature of vanilla had puzzled me for ages. Perhaps this can be a toggle option in settings.cfg when it is implemented, along with the TLF console command. That way we can have cell transitions working both the way it was seemingly intended to by the developers, along with the behavior most players are probably used to.

I don't see much use for the TLF command. I think the setting implementation alone would be sufficient.

#23 Updated by Marc Zinnschlag about 1 year ago

  • Target version changed from openmw-0.41 to openmw-0.42

#24 Updated by Marc Zinnschlag 8 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

#25 Updated by Andrei Kortunov 5 months ago

Also I found a difference: in vanilla Morrowind screen fades BEFORE location change, in OpenMW - AFTER location change.

#26 Updated by Andrei Kortunov 5 months ago

And if you start a new game, a game will fade in both interior->exterior and exterior->interior directions.

Just a guess: maybe a new game and TLF activate fading, but its status does not stored neither in savegame nor INI-file.

#27 Updated by Andrei Kortunov 5 months ago

A console commands such as "COC" are affected too.

#28 Updated by Andrei Kortunov 5 months ago

Anyway, screen fading during cells transitions was designed to work with long loading, but it is bugged in vanilla game (it works fine only for fast travel).

In OpenMW this fading is pretty useless.
Besides, current implementation in OpenMW is broken. To fix it properly we have to add an artificial delay before cell change (to fade screen to black).

I have no idea which behaviour we can treat as correct.

#29 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from New to Feedback needed
  • % Done changed from 0 to 50

#30 Updated by Will Herrmann 4 months ago

Why is fading useless in OpenMW? Because cells transition too quickly? Would it still be useless on slow hardware?

#31 Updated by Andrei Kortunov 4 months ago

Vanilla game uses an artifitial delay (about 1 second) to fade screen before cell changing.
OpenMW by default preload a destination cell, so this delay is almost useless in OpenMW - it is just a wasting of player's time.

Also fading works fine in Morrowind only for fast travel (take a look at comments above).
In OpenMW fading during cell loading is totally broken for now, fading during fast travel is bugged too.

#32 Updated by Will Herrmann 4 months ago

In that case, I like the idea of just removing fading altogether and not trying to replicate it in OpenMW. I don't think it's a strong enough stylistic element to add it, and as you said, we aren't sure what the correct behavior is anyway.

#33 Updated by Lennart Bernhardt 4 months ago

I think that fading is a very powerful stylistic choice in vanilla morrowind - it signals that there is something that was skipped, a strider ride for example, without it everything just looks like a teleport. In this case even a 0.5 - 1 second delay seems very fair.

#34 Updated by Lennart Bernhardt 4 months ago

Tho for doors I agree it's not needed

#35 Updated by Will Herrmann 4 months ago

I would be okay with just fast travel fading.

#36 Updated by scrawl . 3 months ago

  • Target version deleted (openmw-0.43)

#37 Updated by Alexei Dobrohotov 2 months ago

Screen fading out before a loading screen has been implemented in 12510efab7bd2e29f23e5054356718a8847bf763

Should this issue be closed?

#38 Updated by Andrei Kortunov 2 months ago

We still should decide what to do with the fading during cell transitions.
If we do not want to implement it, we should remove its broken code and close this issue.

#39 Updated by scrawl . 2 months ago

Hm... I think as of a4737d84178e0f7ae58ed9364d648d1e9c4c687f , the 'broken' code is not broken anymore. That is, if you go through a door that triggers a loading screen, the screen should fade out while loading. If there's no loading screen, there won't be fading. I haven't tested this though (didn't intend it either, I had no idea there even was a broken fading code).

#40 Updated by scrawl . 2 months ago

Ah, but that code is only present for changeToInteriorCell(). So either we should implement exteriors also, or remove the code.

#41 Updated by scrawl . 2 months ago

  • Status changed from Feedback needed to Closed
  • Target version set to openmw-0.43
  • % Done changed from 50 to 100

Fading for exteriors added in 8c0790580a80431d9f31d7beed07f8e61beae121 .

Basically, OpenMW behaves like vanilla would if 'toggleLoadFade' was always on, except that there's no artificial delay to allow fading to happen so if there isn't enough time to show a loading screen then there won't be fading either.

Also available in: Atom PDF