Project

General

Profile

Bug #815

Different settings cause inconsistent underwater visibility

Added by Anonymous over 4 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Rendering
Target version:
Start date:
06/11/2013
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

If you don't turn both water reflection and refraction you can experience different visibility above/underwater.

deepWater.png View (264 KB) Anonymous, 06/11/2013 08:13 AM

waterdepth.png View (1.43 MB) Miloslav Číž, 09/29/2017 09:32 PM


Related issues

Duplicated by OpenMW - Bug #1988: Graphic glitches (water rendering) Rejected 10/07/2014

History

#1 Updated by Marc Zinnschlag over 4 years ago

  • Target version set to openmw-0.25

#2 Updated by Marc Zinnschlag over 4 years ago

  • Target version changed from openmw-0.25 to openmw-0.26

#3 Updated by Marc Zinnschlag about 4 years ago

  • Target version changed from openmw-0.26 to openmw-0.27

#4 Updated by Marc Zinnschlag about 4 years ago

  • Target version changed from openmw-0.27 to openmw-0.28

#5 Updated by Marc Zinnschlag almost 4 years ago

  • Target version changed from openmw-0.28 to openmw-0.29

#6 Updated by Marc Zinnschlag almost 4 years ago

  • Target version changed from openmw-0.29 to openmw-0.30

#7 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.30 to openmw-0.31

#8 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.31 to openmw-0.32

#9 Updated by Marc Zinnschlag about 3 years ago

  • Target version changed from openmw-0.32 to openmw-0.33

#10 Updated by Marc Zinnschlag about 3 years ago

  • Target version changed from openmw-0.33 to openmw-0.34

#11 Updated by Marc Zinnschlag almost 3 years ago

  • Target version changed from openmw-0.34 to openmw-0.35

#12 Updated by scrawl . almost 3 years ago

  • Duplicated by Bug #1988: Graphic glitches (water rendering) added

#13 Updated by Marc Zinnschlag almost 3 years ago

  • Target version changed from openmw-0.35 to openmw-0.35.1

#14 Updated by Marc Zinnschlag over 2 years ago

  • Target version changed from openmw-0.35.1 to openmw-0.36

#15 Updated by scrawl . over 2 years ago

  • Target version deleted (openmw-0.36)

I'm planning to write a completely new water shader for the OSG port, so tackling this issue now would be more or less a waste of time.

#16 Updated by Jeffrey Haines 11 months ago

  • Subject changed from underwater visibility to Different settings cause inconsistent underwater visibility
  • Status changed from New to Confirmed
  • Target version set to openmw-0.42
  • Reproducibility changed from Have not tried to Always

This is still an issue

#17 Updated by Marc Zinnschlag 8 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

Any update on this issue? Should we close it?

#18 Updated by Who Knows 8 months ago

Marc Zinnschlag wrote:

Any update on this issue? Should we close it?

Why close if it is still a confirmed and not fixed bug? Shouldn't it rather be can'tfix or won'tfix if it's going to be ignored (closed in this state)?

#19 Updated by Marc Zinnschlag 8 months ago

We don't have "won't fix". We have "rejected", which is actually what I meant. Sorry for being imprecise.

#20 Updated by Alexei Dobrohotov 3 months ago

  • Target version changed from openmw-0.43 to openmw-1.0

#21 Updated by Miloslav Číž about 2 months ago

Does the issue still stand? I recently fiddled with the water shader and also updated the way water depth is computed and now when I check this, the issue seems to no longer be there. Could anyone confirm and/or close this?

#22 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from Confirmed to Closed
  • Assignee set to Miloslav Číž
  • Target version changed from openmw-1.0 to openmw-0.43
  • % Done changed from 0 to 100

Seems to be resolved after your changes.

0.42.0 does have this issue, so I set 0.43.0 milestone.

Also available in: Atom PDF