Project

General

Profile

Bug #793

AIWander Isn't Being Passed The Repeat Parameter

Added by Torben Carrington almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
05/24/2013
% Done:

100%

Spent time:
Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

There is a missing parameter from AIWander. This is the repeat parameter and is listed after idle9 in the parameters list, this gets passed as a 0 by default if there are only 3 parameters passed but if a single idle parameter is listed it gets passed as 1. It can also be specified, but only if all 9 idle parameters are as well:
AIWander 500 2 0 0 0 0 0 0 0 0 0 0 *0*
This will make repeat be passed as 0 even though there are idles being specified. Although:
AIWander 500 2 0 0
Will pass repeat as 1 because at least one idle parameter is specified and the repeat parameter is not specified as 0.

Read more here: https://forum.openmw.org/viewtopic.php?f=6&t=1556&p=16231

History

#1 Updated by Torben Carrington almost 4 years ago

  • Assignee set to Torben Carrington

#2 Updated by Torben Carrington almost 4 years ago

  • Target version changed from openmw-0.25 to openmw-0.24
  • % Done changed from 0 to 100

#3 Updated by Torben Carrington almost 4 years ago

  • Status changed from New to Resolved

#4 Updated by Torben Carrington almost 4 years ago

  • Status changed from Resolved to Closed
  • Target version changed from openmw-0.24 to openmw-0.25

Also available in: Atom PDF