Project

General

Profile

Bug #752

The enter button has several functions in trade and looting that is not impelemted.

Added by William Sogge almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
05/01/2013
% Done:

100%

Spent time:
Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Pressing the enter button when looting a container/dead npc should give you all the inventory. The enter button also
works as a way to confirm or ok stuff in other menus in vanilla.

History

#1 Updated by Kenny Armstrong almost 4 years ago

  • Assignee set to Kenny Armstrong

#2 Updated by William Sogge almost 4 years ago

Additional info.

Just so you're not misled, this has to do with the button that is assigned to do activation, and is not a fixed function key like ESC.

#3 Updated by Kenny Armstrong almost 4 years ago

Thanks for the info. I'll make sure that it operates as expected.

#4 Updated by Kenny Armstrong almost 4 years ago

  • Status changed from New to In Progress

I don't know about the accuracy of this bug.

In a fresh install of vanilla, I went to containers and pressed the Enter key, and it did not give me all of the contents. I had to press 'Take All' for me to empty the container. This functionality is exactly the same in OpenMW.

As for confirming other message boxes and such, this already works the same in OpenMW as it does in vanilla.

Also in vanilla, I pressed the Enter key to loot a corpse, and that also did nothing. I had to press Take All or Dispose of Corpse.

As I understand the bug, the functionality of this is the same between vanilla and OpenMW, unless I still don't understand the actual bug.

#5 Updated by Lars Söderberg almost 4 years ago

As far as I know, what you describe is the way vanilla works and not as William described.
I created a forum topic on the subject a while back:
https://forum.openmw.org/viewtopic.php?f=3&t=1490
The conclusion as I understood it was that features not existing in vanilla should not be replicated pre-1.0. My personal opinion is however similar to what William described since I see no downside with it, but that is beside the point.

#6 Updated by Kenny Armstrong almost 4 years ago

Ok, I see what you are saying.

However, from my testing today, what we already have replicates vanilla, and pre-1.0, nothing should be going in that does not adhere to how vanilla already works (from what I understand).

So, the way I'm reading this, is that this isn't necessarily a bug, but in fact a post 1.0 feature request.

@Zini,scrawl: am I incorrect on this? Am I still reading this wrong?

#7 Updated by William Sogge almost 4 years ago

Ok checked it and i didn't get it quite right, did some testing and now i know what was missing

In vanilla: When you have you inventory up and your going to pick up an item you have 2 or more of, you can
click on it with your mouse (or button of your choice) and press enter to pick up everything of that item (if you don`t need a certain amount of it) instead of having to press the ok in the trade window and then move it to where you want it.

You can`t to this in OpenMW

#8 Updated by Kenny Armstrong almost 4 years ago

Ok, now I understand.

When I tested on vanilla, the activation key and the enter key accepted the multiple item transaction. OpenMW does not do this.

I will look into this.

#9 Updated by Kenny Armstrong almost 4 years ago

Notes to self:

the files needed to be modified: apps/openmw/mwgui/coundtialog.hpp and countdialog.cpp

have a look at http://mygui.info/docs/class_my_g_u_i_1_1_widget_input.html#a9c0c205a1523715242cb07f3e1bb0018 for MyGUI handling key presses. In the countdialog window, the text edit box for modifying an item's amount has the focus.

#10 Updated by Kenny Armstrong almost 4 years ago

  • % Done changed from 0 to 80

Enter button now accepts multiple items in coundialog window.

#11 Updated by Kenny Armstrong almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Marking this as resolved for now, since the bug originally reported the Enter key not performing this function.

I need to review the code further to figure out how to get the activate key to also do this task, however, that should likely be a separate features, since as far as I can tell, this is the only dialog window where the 'activate' key closes a window.

#12 Updated by Kenny Armstrong almost 4 years ago

  • Status changed from Resolved to Closed

created Feature #786 for the activate key. closing this.

Also available in: Atom PDF