Project

General

Profile

Bug #672

incorrect trajectory of the moons

Added by Yann GOUY almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
Start date:
03/28/2013
% Done:

100%

Spent time:
Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

the 2 moons are centered on the same point the first day at midnight.

in vanilla, it is not the case.

the small white moon is moving faster than the red big one.
their trajectories are not in the same plan.

moons.ods (23.1 KB) Roman Proskuryakov, 05/11/2013 07:12 PM

sg.png View (20.9 KB) Anonymous, 05/28/2013 06:30 AM

Associated revisions

Revision 24ba54f4 (diff)
Added by Chris Boyce over 1 year ago

Implement accurate moon settings (fixes #672)

History

#1 Updated by Marc Zinnschlag almost 4 years ago

  • Category changed from World Model to General
  • Target version set to openmw-0.23

#2 Updated by Michał Bień almost 4 years ago

  • Assignee set to Michał Bień

#3 Updated by Marc Zinnschlag almost 4 years ago

  • Target version changed from openmw-0.23 to openmw-0.24

#4 Updated by Roman Proskuryakov almost 4 years ago

Added moons.ods with the current calculation of the trajectory of the moons.

I figured out that the moons should move approximately from 135° (NW) to -45° (SE)

The code is located in apps/openmw/mwworld/weather.cpp

#5 Updated by Michał Bień almost 4 years ago

Thanks, amazing work! How have you discovered these values?

#6 Updated by Michał Bień almost 4 years ago

Ok, sorry, I thought you've reversed values from vanillia Morrowind. But anyway, great help!

#7 Updated by Anonymous almost 4 years ago

Did you tried looking into World Scene Graph (ShowSceneGraph console cmd)?
It takes some time (more than minute in Wine).

#8 Updated by Michał Bień almost 4 years ago

I feel stupid. I didn't even know that there is something like that

#9 Updated by Anonymous almost 4 years ago

Seems like it contains both rotation and position. It is possible to translate it directly into OMW rendering engine? Are these values meaningful for OMW?

#10 Updated by Anonymous almost 4 years ago

Now I feel stupid for my poor English...

#11 Updated by Anonymous over 3 years ago

I am gathering information about trajectories. I am not sure if it's possible to export data from ShowSceneGraph window - it might be necessary to write it manually.

#12 Updated by Michał Bień over 3 years ago

We need reversed formula, adjusting manually is not good idea while we have lots of moons variables in openmw.cfg (imported from Morrowind.ini)

#13 Updated by Anonymous over 3 years ago

Yes, it will take some time. Running 'ssg' takes few minutes and then you must restart game to get another one - maybe by running wine multiple times. And you must make screenshots because it's not possible to copy anything from Scen Graph window.

Position depends only on 'gamehour'. Moons transparency seems to be
Masser: 100% -> 0% at 22 -> 23 hours and then 0% -> 100% at 6 -> 9 hours,
Secunda: 100% -> 0% at 23.7 -> 0.3 and then it disappears at same time as Masser.

#14 Updated by Anonymous over 3 years ago

To be clear - we have two moons (Masser and Secunda), right? Plus the Sun.

#15 Updated by Michał Bień over 3 years ago

  • Assignee deleted (Michał Bień)
  • % Done changed from 0 to 40

I'm planning to work on editor now, so disowning this task.

#16 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.24 to openmw-0.25

#17 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.25 to openmw-0.26

#18 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.26 to openmw-0.27

#19 Updated by Marc Zinnschlag over 3 years ago

  • Target version changed from openmw-0.27 to openmw-0.28

#20 Updated by Marc Zinnschlag about 3 years ago

  • Target version changed from openmw-0.28 to openmw-0.29

#21 Updated by Marc Zinnschlag about 3 years ago

  • Target version changed from openmw-0.29 to openmw-0.30

#22 Updated by Marc Zinnschlag almost 3 years ago

  • Target version changed from openmw-0.30 to openmw-0.31

#23 Updated by Marc Zinnschlag over 2 years ago

  • Target version changed from openmw-0.31 to openmw-0.32

#24 Updated by Marc Zinnschlag over 2 years ago

  • Target version changed from openmw-0.32 to openmw-0.33

#25 Updated by Marc Zinnschlag over 2 years ago

  • Target version changed from openmw-0.33 to openmw-0.34

#26 Updated by Marc Zinnschlag about 2 years ago

  • Target version changed from openmw-0.34 to openmw-0.35

#27 Updated by Marc Zinnschlag about 2 years ago

  • Target version changed from openmw-0.35 to openmw-0.35.1

#28 Updated by Marc Zinnschlag almost 2 years ago

  • Target version changed from openmw-0.35.1 to openmw-0.36

#29 Updated by Taylor Gronka almost 2 years ago

I'd like to fix this issue. I'm curious though - would it be better to replicate the moons from Morrowind as closely as possible? Or would it be better to dig into the lore to make them lore and astronomically friendly (I've seen some debate as to whether the moons are actually moons or spirits, etc)

#30 Updated by Mark Simpson almost 2 years ago

Taylor Gronka wrote:

I'd like to fix this issue. I'm curious though - would it be better to replicate the moons from Morrowind as closely as possible? Or would it be better to dig into the lore to make them lore and astronomically friendly (I've seen some debate as to whether the moons are actually moons or spirits, etc)

Anything that open to interpretation has to be better suited for a mod I think. Reproducing Morrowind's original behaviour is the best solution for OpenMW.

#31 Updated by Marc Zinnschlag almost 2 years ago

  • Target version changed from openmw-0.36 to openmw-0.37

#32 Updated by Marc Zinnschlag over 1 year ago

  • Status changed from New to Closed
  • % Done changed from 40 to 100
  • Operating system changed from Linux to Other

#33 Updated by Jannik Heller over 1 year ago

Why is this marked closed? The pull request 699 was not merged yet.

Also available in: Atom PDF