Project

General

Profile

Bug #564

OpenMW has issues when running on Big Endian CPU

Added by Douglas Mencken almost 5 years ago. Updated 2 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
02/16/2013
% Done:

0%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

Currently, OpenMW is playable only on machines which have Little Endian CPUs (like 80x86 and compatibles).
Main issue here is reading/writing Morrowind data files, especially ESM files.


Related issues

Duplicated by OpenMW - Bug #3849: ESM Error: Unknown subrecord on ppc64 Rejected 04/30/2017

History

#1 Updated by Jeffrey Haines 11 months ago

  • Status changed from New to Closed

Abandoned. Closed.

#2 Updated by Miroslav Remák 11 months ago

  • Status changed from Closed to New

What do you mean abandoned? This is still an issue AFAIK.

#3 Updated by Miroslav Remák 11 months ago

  • Assignee deleted (Douglas Mencken)
  • % Done changed from 20 to 0

#4 Updated by Jeffrey Haines 11 months ago

Yes it's still a problem, but in terms of being an issue we'll likely act upon it's pretty much "won't fix."

I see this as better left Closed or Rejected until it becomes relevant again.

Leaving issues open that are abandoned and likely not fixable isn't really healthy for our bug tracker/statistics.

#5 Updated by Jeffrey Haines 11 months ago

Also I did make a mistake, this should be rejected not closed.

As per the bug reporting guidelines:

https://wiki.openmw.org/index.php?title=Bug_Reporting_Guidelines

"Rejected - The issue was invalid. This can happen for several reasons:...
3. The bug is not reasonably fixable due to constraints outside of our control."

I think we can reasonably assume our target software architecture is x86 little endian. So the likely hood we'd continue to support big endian is unreasonable, therefore we should reject this until we have a reason to think it will be resolved and closed.

#6 Updated by Miroslav Remák 11 months ago

Fixing this is certainly not outside of our control. In fact, it doesn't even seem that difficult to do, it's just lots of work. The only thing rejecting this (perfectly valid) bug would achieve is deter potential developers from working on it.

Also, we're already "supporting" multiple architectures, some of which are big-endian: https://packages.debian.org/sid/openmw#pdownload

#7 Updated by Jeffrey Haines 11 months ago

Building and "supporting" are two separate terms. If they don't work on big-endian machines and we don't support them (get them working and have the capacity to assist in supporting), then this bug serves little purpose at this point.

#8 Updated by Alexei Dobrohotov 11 months ago

And?

#9 Updated by Miroslav Remák 11 months ago

@Jeffrey: Point is some people who download OpenMW from official sources can't play the game at all. There is no harm in keeping this bug up other than it bothering you because you're not affected by it. I am not going to discuss this further. If you want to, take it to the forums.

#10 Updated by Jeffrey Haines 11 months ago

And... We should either keep this bug as a catch all for any big endian fans or we should save some time, for now, and discontinue big endian builds, especially if they do not work.

#11 Updated by scrawl . 7 months ago

  • Duplicated by Bug #3849: ESM Error: Unknown subrecord on ppc64 added

#12 Updated by scrawl . 2 months ago

  • Status changed from New to Confirmed
  • Target version deleted (openmw-future)

Also available in: Atom PDF