Project

General

Profile

Bug #4343

Error message for coc and starting cell shouldn't imply that it only works for interior cells

Added by Will Herrmann 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
General
Target version:
Start date:
03/05/2018
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

When using the coc command, or when starting with the --start command, if the cell name doesn't exist, the error message says that an "interior cell" by that name cannot be found.

openmw --start=balmor
Failed to start new game: Interior cell 'balmor' not found

> coc balmor
Error: Interior cell 'balmor' not found

In both cases, these are actually exterior cells, and even using --start for unnamed exterior cells works now.

I think that the message should be changed because it implies that only interior cells work with it. This came up in Discord recently.

I can't get it to work with base game exterior cells, and the error is something along the lines of 'interior cell not found <cell name>', which I took to mean "this function, when working, is only supposed to be for interiors" which in vanilla isn't the case

Therefore, I'd like to propose that we drop the word "Interior", instead stating simply:

Error: Cell 'balmor' not found

History

#1 Updated by scrawl . 3 months ago

  • Status changed from New to Confirmed

#2 Updated by Will Herrmann 3 months ago

  • Category set to General
  • Status changed from Confirmed to Resolved
  • Assignee set to Will Herrmann
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100

Fixed by PR #1626

#3 Updated by Will Herrmann 3 months ago

  • Status changed from Resolved to Closed

PR is merged.

Also available in: Atom PDF