Project

General

Profile

Bug #4322

NPC disposition: negative faction reaction modifier doesn't take PC rank into account

Added by rot tor 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
02/09/2018
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

OpenMW does take rank into account for the positive faction reaction modifier:
https://wiki.openmw.org/index.php?title=Research:Disposition_and_Persuasion

x += (fDispFactionRankMult * rank + fDispFactionRankBase) * fDispFactionMod * reaction

but doesn't do the same for negative reactions.

There is also a design bug in vanilla. Only the faction with the most negative reaction is used, even if rank in another faction should have given a more negative reaction.
Example:
Temple has -1 reaction to Telvanni, and -3 reaction to Sixth House.
If the player is rank 9 Telvanni, they get -17 disposition with Temple NPCs,
if that player joins the Sixth House, it turns to -3 disposition because the Sixth House modifier is used instead.

Associated revisions

Revision f626a7fc (diff)
Added by Andrei Kortunov 2 months ago

Take in account PC rank during disposition calculation (bug #4322)

History

#1 Updated by rot tor 2 months ago

I didn't phrase that correctly: what currently does take rank into account is the SAME faction modifier (always positive), and it seems what does not is the modifier for OTHER factions (not always negative)

#2 Updated by Andrei Kortunov 2 months ago

  • Status changed from New to Feedback needed

Related code is here.

OpenMW indeed does not take in account player's rank in the "faction with the most negative reaction" (we do not initialize the "rank" variable).
How does vanilla game behave in this case? If Morrowind takes rank in account, I can fix this bug.

#3 Updated by Andrei Kortunov 2 months ago

  • Operating system changed from Windows to Other

#4 Updated by Andrei Kortunov 2 months ago

And I suppose ranks take multipliers from 1 to 10, right?

#5 Updated by Andrei Kortunov 2 months ago

Ok, Morrowind uses multipliers from 0 to 9. Also Morrowind ignores the faction, if the player was expelled from it.

#6 Updated by Andrei Kortunov 2 months ago

  • Status changed from Feedback needed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100

#7 Updated by Andrei Kortunov 2 months ago

  • Status changed from Resolved to Closed

#8 Updated by rot tor 2 months ago

Looks like you fixed the vanilla bug too, thanks!

Also available in: Atom PDF