Project

General

Profile

Bug #4320

Using mouse 1 to move forward causes selection dialogues to jump selections forward.

Added by Maarten Foqué 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Input
Target version:
Start date:
02/09/2018
% Done:

100%

Reproducibility:
Always
Operating system:
Windows
Severity:
Normal

Description

Examples:
1. When the value box of a barter screen is selected, it will automatically start incrementing. (as if pushing the + button)
2. When selecting your character race in a new game, the race selection will "increase" to the top.

When choosing a keyboard button for moving forward, this behaviour stops.
Switching back to mouse 1 for moving forward, brings the behaviour back.

This is new since openMW 0.43. This did not cause issues in openMW 0.42.

Associated revisions

Revision f28024b5 (diff)
Added by scrawl . 2 months ago

Don't use Activate and Move keys for GUI navigation if bound to mouse buttons (Fixes #4225, Fixes #4320)

History

#1 Updated by Alexei Dobrohotov 2 months ago

  • Category set to Input

#2 Updated by scrawl . 2 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#3 Updated by Andrei Kortunov 2 months ago

  • Assignee set to scrawl .
  • Target version set to openmw-0.44

Also available in: Atom PDF