Project

General

Profile

Bug #4309

Only harmful effects with resistance effect set are resistable

Added by rot tor 4 months ago. Updated 1 day ago.

Status:
Resolved
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
01/28/2018
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Frenzy is always increasing Fight by 100% magnitude in OpenMW,

In the original engine it increases Fight by 150% magnitude on High Elves and by 50% on Bretons.

History

#1 Updated by Andrei Kortunov 3 months ago

It originally increases Fight by 1.5 : 1 magnitude.

Can not reproduce this behaviour with vanilla game.
I thought that Resistance to Magic is involved, but High Elven with 50% Weakness to Magic still got 1:1 in my testing in both Morrowind and OpenMW.

Also the Frenzy with X magnitude is documented to inscrease Fight by X.

#2 Updated by Andrei Kortunov 3 months ago

  • Status changed from New to Feedback needed

From the other hand, what's your test case?

#3 Updated by rot tor 3 months ago

My mistake then, the issue is certainly that some 50% Weakness didn't modify the effect in OpenMW, and not the general effect's magnitude,
I don't have the plugin but tested Frenzy 5 or Frenzy 40 on the same object in both engines. In the original engine with or without MCP I got GetFight to report 1.5x magnitude rounded down, but I also noted that the returned Fight value could be 1 less at random, so maybe you won't see the effect of 50% weakness if the base Frenzy magnitude is only 2 or 3.

"Resist Magicka" probably has the opposite effect.

#4 Updated by Andrei Kortunov 3 months ago

Tested with original engine:
1. Maginitude 5, no weaknesses, Fight = 30: GetFight returns 35.
2. Maginitude 5, 50% Weakness to Magic (High Elf target, e.g. Arrille), Fight = 30: GetFight returns 35, sometimes 34.
So we would require an independent testing.

Basically we should determine if illusion effects are affected by magic weakness/resistance or not.

#5 Updated by rot tor 3 months ago

I tried again on Arrille and High Elf NPCs, and also got 0.5x magnitude on Bretons (50% Resist). Same with the Charm effect. It's strange that it isn't documented anywhere though. Maybe it's a difference in exe versions? I tested on the English version (v1.6.1820)

#6 Updated by Andrei Kortunov 3 months ago

  • Subject changed from Frenzy spell has lower magnitude effect to Illusion AI-related magic effects do not take in account Resistance/Weakness to magic
  • Status changed from Feedback needed to Confirmed
  • Operating system changed from Windows to Other

Ok, I managed to reproduce this issue on Windows. Maybe I encountered a bug in WINE during initial Linux testing.

So we should apply magic resistance/weakness to the magnitude of all similar magic effects.

#7 Updated by Andrei Kortunov 3 months ago

After additional research I figured out that MagicResistance/SpellReflection do not work for effects without Harmful flag
Related code is here.
Not sure how original game determines if it should apply resistance or no.

#8 Updated by rot tor 3 months ago

If resist doesn't have special exceptions maybe it also applies to effects with the Stealth flag? 8192 according to MWSE doc, but not sure if it's for these illusion spells or not.

Also, "Resist Magicka" shouldn't apply to effects that have their own resistance effect (Paralysis, Fire, Frost, Shock, Poison, and I think diseases). UESP reports that it doesn't apply to effects without magnitude (Silence) but that's incorrect.

#9 Updated by rot tor 3 months ago

#10 Updated by rot tor 3 months ago

Besides the above exceptions and Sun Damage, the only harmful effects that Resist Magicka doesn't affect in vanilla are the Disintegrate ones (Weap/Arm). That might be a bug though, since as the above link says they're resisted by Sanctuary, and there's nothing that suggests Sanctuary is supposed to have that effect.

#11 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Alexei Dobrohotov
  • Target version set to openmw-0.44

#12 Updated by Alexei Dobrohotov about 2 months ago

  • Description updated (diff)

#13 Updated by Alexei Dobrohotov about 1 month ago

  • Subject changed from Illusion AI-related magic effects do not take in account Resistance/Weakness to magic to Only harmful effects with resistance effect set are resistable
  • % Done changed from 0 to 100

#14 Updated by bret curtis 1 day ago

Is there a PR for this?

Also available in: Atom PDF