Project

General

Profile

Bug #4288

Fatal Error Address not mapped to object (signal 11) when saving a game

Added by Michael Feuerherd 14 days ago. Updated about 16 hours ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/09/2018
% Done:

0%

Reproducibility:
Always
Operating system:
Linux
Severity:
Major

Description

Hi Guys, since yesterday I have issues with my openmw installation. Before, it ran just fine.
I run:
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
I've installed the GotY-Version 2.0.0.7 via wine 1.6.2 and the openmw 0.4.3.0 via launchpad.
I've tried to re-install, but the fatal error persists.
Yesterday I had another fatal error, when loading into a new cell (i.e. from one door to another, Almalexia's Throne Room into the Temple-rooms in Mournhold), but this is not the issue any longer.
Furthermore I had to tell the Morrowind-config-File manually wher to find the data files - the installation wizard could not handle the directory and the files within properly.

I post the latest log-file as an attachment.

crash.log View - crash.log (27.4 KB) Michael Feuerherd, 01/09/2018 11:53 AM

latest-save-game.tar.gz (3.9 MB) Michael Feuerherd, 01/09/2018 12:00 PM

History

#1 Updated by Michael Feuerherd 14 days ago

Additional info:
Addons: Tribunal, Bloodmoon; no mods
English is the language.
With this post I attach my save-file.

#2 Updated by scrawl . 14 days ago

The game crashed in your graphics driver when copying the screen to a texture. That's probably a bug in the driver, a borked GPU or not enough memory. How much RAM & VRAM do you have?

#3 Updated by Michael Feuerherd 13 days ago

@scrawl .: thanks. My $ dmesg | grep drm says:
[ 1.157118] [drm] Initialized drm 1.1.0 20060810
[ 1.369374] [drm] Memory usable by graphics device = 2048M
[ 1.369379] fb: switching to inteldrmfb from VESA VGA
[ 1.369484] [drm] Replacing VGA console driver
[ 1.377197] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 1.377199] [drm] Driver supports precise vblank timestamp query.
[ 1.397184] [drm] Initialized i915 1.6.0 20151010 for 0000:00:02.0 on minor 0
[ 1.419137] fbcon: inteldrmfb (fb0) is primary device
[ 1.419229] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
My Ram is: $ free -m
gesamt benutzt frei gemns. Puffer/Cache verfügbar
Speicher: 7779 2467 172 351 5138 4585
Auslagerungsspeicher: 7985 0 7985

#4 Updated by scrawl . 12 days ago

Ok, so you have 2gb vram and 8gb ram. That should be enough for an installation without mods.

Since you mentioned that 'since yesterday I have issues with my openmw installation. Before, it ran just fine.'. Do you recall anything you did just before the issues started? Maybe you installed an update to your graphics driver?

#5 Updated by Michael Feuerherd 12 days ago

Indeed. There were some changes. First, I tested second-hand RAM in my system. The RAM was corrupted, so Ubuntu didn't start, Memtest crashed. I re-inserted my Lenovo RAM and the system seemed fine, everything was recognized properly, i.e. the full amount of 8GB RAM.
Second, according to my apt-history, I found:
$ less /var/log/apt/history.log
[...]
Start-Date: 2018-01-08 18:15:27
Commandline: aptdaemon role='role-commit-packages' sender=':1.102'
Install: libllvm5.0:amd64 (1:5.0-3~16.04.1, automatic), libllvm5.0:i386 (1:5.0-3~16.04.1, automatic), libdrm-common:amd64 (2.4.83-1~16.04.1, automatic)
Upgrade: poppler-utils:amd64 (0.41.0-0ubuntu1.5, 0.41.0-0ubuntu1.6), libxatracker2:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), libegl1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), libgbm1:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), libdrm-amdgpu1:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libdrm-amdgpu1:i386 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libwayland-egl1-mesa:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), libdrm2:amd64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libdrm2:i386 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libgl1-mesa-dri:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), libgl1-mesa-dri:i386 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), mesa-vdpau-drivers:amd64 (17.0.7-0ubuntu0.16.04.2, 17.2.4-0ubuntu1~16.04.2), libpoppler-glib8:amd64 (0.41.0-0ubuntu1.5, 0.41.0-0ubuntu1.6), libpoppler58:amd64 (0.41.0-0ubuntu1.5, 0.41.0-0ubuntu1.6)
End-Date: 2018-01-08 18:15:36
[...]
This should be the log-entry you are looking for, since it lists changes in the driver. And right after that, also according to my log file, I tried to re-install openmw.
What can I do now? Thanks in advance.

#6 Updated by Andrei Kortunov 12 days ago

At least you can try to downgrade your driver package (libgl1-mesa-dri, I suppose) and check if the downgrade fixes this issue.
Can any Ubuntu user with an Intel GPU confirm this bug?

#7 Updated by Michael Feuerherd 12 days ago

Thanks Andrei Kortunov.
Unfortunately, it seems as if the older version is no longer available from apt-get

$ apt-get install libegl1-mesa=17.0.7-0ubuntu0.16.04.2
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Version »17.0.7-0ubuntu0.16.04.2« für »libegl1-mesa« konnte nicht gefunden werden.
i.e. "Couldn't be found"
Did I do anything wrong?
$ apt-cache showpkg libegl1-mesa
doesn't list anything in the repository before 17.2.4
Building from source is not really an option for me because I am just a beginner.

#8 Updated by Michael Feuerherd about 17 hours ago

Hi folks,
today there was an update from the Ubuntu repos, updating the mesa-drivers, too, and my bug has been magically dissolved. Thanks to the unknown bug-fixer. This thread can be closed.

#9 Updated by Alexei Dobrohotov about 16 hours ago

  • Status changed from New to Closed

Also available in: Atom PDF