Project

General

Profile

Bug #4269

Crash when hovering the faction section and the 'sAnd' GMST is missing (as in MW 1.0)

Added by Cesare Tirabassi 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
GUI
Target version:
Start date:
12/16/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Critical

Description

CTD while hovering over the faction section of the player menu.
The error message is:

ERROR: GameSetting 'sand' not found.

This only happens with a vanilla installation from an original (2002) CD.
I just downloaded the GOTY edition from GoG and the issue is gone, so I believe it is somewhat linked to some data which is missing in the original esm file?
Please let me know if I can help in any way to solve this.

Associated revisions

Revision d9d8de30 (diff)
Added by scrawl . about 1 month ago

Catch exceptions in updateWindowManager (Bug #4269)

Revision e2e48e0a (diff)
Added by scrawl . about 1 month ago

Add default value for 'sAnd' GMST (Fixes #4269)

History

#1 Updated by Randy Davin 2 months ago

Cesare Tirabassi wrote:

This only happens with a vanilla installation from an original (2002) CD.

#2 Updated by R. D. 2 months ago

That setting might have been added in a patch. Did you not apply any patch to the installation from the original CD? It might be that OpenMW doesn't support early versions of Morrowind.

#3 Updated by Cesare Tirabassi 2 months ago

R. D. wrote:

That setting might have been added in a patch. Did you not apply any patch to the installation from the original CD?

No.

It might be that OpenMW doesn't support early versions of Morrowind.

Well, beside this everything else was peach and dandy :), and this was just an annoyance after all.

PS. Would you know where in the source code this error message is generated? I couldn't grep anything sensible...

#4 Updated by R. D. 2 months ago

Would you know where in the source code this error message is generated?

Not sure. I looked for it but I don't see it.

#5 Updated by scrawl . 2 months ago

It might be that OpenMW doesn't support early versions of Morrowind.

No, it's supposed to support it (apart from the things that the patch fixes; so it's still highly recommended to use the patch)

See the 'Morrowind 1.0' status here:

https://wiki.openmw.org/index.php?title=GMSTs_(status)#GMSTs

Looks like we forgot to mark 'sAnd' as implemented and not in Morrowind 1.0.

Additionally, errors in a tooltip should not crash the whole game. This updateWindowManager is missing exception handling (a regression from when it was moved outside of frame()).

PS. Would you know where in the source code this error message is generated? I couldn't grep anything sensible...

The tooltip text is here: https://github.com/OpenMW/openmw/blob/master/apps/openmw/mwgui/statswindow.cpp#L623

#6 Updated by scrawl . 2 months ago

  • Priority changed from Normal to High
  • Severity changed from Normal to Critical

#7 Updated by Cesare Tirabassi 2 months ago

scrawl . wrote:

It might be that OpenMW doesn't support early versions of Morrowind.

No, it's supposed to support it (apart from the things that the patch fixes; so it's still highly recommended to use the patch)

See the 'Morrowind 1.0' status here:

https://wiki.openmw.org/index.php?title=GMSTs_(status)#GMSTs

Looks like we forgot to mark 'sAnd' as implemented and not in Morrowind 1.0.

Additionally, errors in a tooltip should not crash the whole game. This updateWindowManager is missing exception handling (a regression from when it was moved outside of frame()).

PS. Would you know where in the source code this error message is generated? I couldn't grep anything sensible...

The tooltip text is here: https://github.com/OpenMW/openmw/blob/master/apps/openmw/mwgui/statswindow.cpp#L623

Ahhhh, it all makes sense now. Thanks a bunch!

#8 Updated by scrawl . about 2 months ago

  • Subject changed from CTD while hovering over the faction section of the player menu (linux build, v0.43) to Crash when hovering the faction section and the 'sAnd' GMST is missing (as in MW 1.0)

#9 Updated by scrawl . about 1 month ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#10 Updated by Miroslav Remák about 1 month ago

  • Category changed from Sound/Other Media to GUI
  • Target version set to openmw-0.44

Also available in: Atom PDF