Project

General

Profile

Support #4266

openmw 043.0 crashed to desktop

Added by Lone Wolf 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/13/2017
% Done:

0%

Operating system:
Linux
Severity:
Normal

Description

I was close to Maar Gan and under attack by an NPC .
Right-clicked to check who it was, Zanat Assarnuridan, then got a message from openmw it had crashed.

Crash log and other config files attached.

after re-launching openmw and loading quicksave everything was fine.

crash.log View (19.9 KB) Lone Wolf, 12/13/2017 02:51 AM

input_v3.xml View (14 KB) Lone Wolf, 12/13/2017 02:51 AM

launcher.cfg (24.6 KB) Lone Wolf, 12/13/2017 02:51 AM

settings.cfg (1.01 KB) Lone Wolf, 12/13/2017 02:51 AM

wizard.log View (49 Bytes) Lone Wolf, 12/13/2017 02:51 AM

openmw-normal.log View - log file from after crash (12.8 KB) Lone Wolf, 12/13/2017 03:00 AM

History

#1 Updated by scrawl . 4 months ago

The crash seems to be deep in your graphics driver.

I'm afraid that without a debug build or steps to reproduce there isn't something we can do about this, and it's impossible to say at this point if the issue in OpenMW, in the graphics driver or with your graphics card.

#2 Updated by Lone Wolf 4 months ago

My graphics card is an AMD HD 4870 from 2009 and running openmw does raise it's temperature & fan speed.

I'll add vsync = true to my settings.cfg , that should reduce the load on the card.

#3 Updated by Lone Wolf 4 months ago

Running with vsync on did mitigate the issue, but i had 2 or 3 more 3 crashes. Those weren't caught by openmw though.
checking my /var/log/everything.log files indicated the problems were reported by libdrm.

I run arch linux along with latest libdrm-git, mesa-git and llvm-svn, so my installed sw versions change often.
I haven't had a crash from openmw since dec 23 now.

What i did notice was that rain or ash storms very often had a bad effect on fps (like lowering from 60 to 15 ...).
saving and reloading didn't help, unless i exited openmw first.

I'm thinking gpu power management may play a big part in this.
Can openmw / osg / boost etc influence power states of gpu ?

#4 Updated by Lone Wolf 3 months ago

I've played openmw a lot of hours this year and have not encountered the issue again.
Changing some power related settings on my system helped a lot with maintaining stable fps in graphics heavy situations like ash and rain storms.

I no longer think this issue is an openmw bug and propose to close it.

#5 Updated by Alexei Dobrohotov 3 months ago

  • Tracker changed from Bug to Support
  • Status changed from New to Closed

Also available in: Atom PDF