Project

General

Profile

Bug #4252

"Error in frame: FFmpeg exception: Failed to allocate input stream" message spam if OpenMW encounter non-music file in the Music folder

Added by R C 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
Sound/Other Media
Target version:
Start date:
12/08/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Hey guys!

Weird bug I'm having where after an hour or so of playing, the PC starts moving in slow motion. FPS does NOT change, just movement speed (even though Speed skill remains the same). The console spams this message over and over:

Error in framelistener: FFmpeg exception: Failed to allocate input stream
Playing music/explore/.ds_store
Error in framelistener: FFmpeg exception: Failed to allocate input stream
Playing music/explore/.ds_store
Error in framelistener: FFmpeg exception: Failed to allocate input stream

Etc..

Screen Shot 2017-12-08 at 4.19.51 AM.png View (238 KB) R C, 12/08/2017 04:20 AM


Related issues

Duplicated by OpenMW - Bug #4133: [Regression] [Mod] Abot's Boats no longer works with newer Nightly Builds Rejected 09/30/2017

History

#1 Updated by Andrei Kortunov 5 months ago

What is .ds_store?

#2 Updated by Plutonic Overkill 5 months ago

IIRC, .ds_store is a MacOS specific file storing stuff like layout information, thumbnails, etc. for each directory, a bit like thumbs.db on Windows. I think the problem is that OpenMW does not filter the filetype of music tracks, e.g. in this function. I managed to reproduce this issue by placing random garbage files in the music/explore directory.

#3 Updated by Plutonic Overkill 5 months ago

On second thoughts, does this issue occur for other sound types, such as sound effects? If so it might be better to place a check in the actual sound code rather than in the music playing code.

#4 Updated by Andrei Kortunov 5 months ago

  • Subject changed from Music stops playing, character begins to move in slow-mo (NOT FPS drop), console spams "Error in framelistener: FFmpeg exception: Failed to allocate input stream" to "Error in frame: FFmpeg exception: Failed to allocate input stream" message spam if OpenMW encounter non-music file in the Music folder
  • Category set to Sound/Other Media
  • Status changed from New to Confirmed
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from MacOS to Other

I think the problem is that OpenMW does not filter the filetype of music tracks,

Yes, you are right.
Currently this bug appears if OpenMW encounters non-music file (e.g. the hidden service one) in the Music folder. OpenMW tries to play this file again and again. I guess it should:
1. Try to play only files with supported extensions
2. Even if OpenMW failed to allocate input stream, it should just play another sound.

To OP: as temporary workaround, you can remove your hidden .ds_store file from the Music/Explore folder.

#5 Updated by Andrei Kortunov 5 months ago

does this issue occur for other sound types, such as sound effects?

Maybe: #4133

#6 Updated by Plutonic Overkill 5 months ago

So should this bug be marked as 'In Progress' if it is being worked on?

#7 Updated by Chris Robinson 4 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to Chris Robinson
  • Target version set to openmw-0.44
  • % Done changed from 0 to 70

#8 Updated by Chris Robinson 4 months ago

It's the same issue as in #4133. Failing to open an audio file (either because it doesn't exist, it's not a supported format, or it's not actually an audio file) throws an exception that's not properly handled. I'm working on it now.

#9 Updated by Chris Robinson 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 70 to 100

#10 Updated by Alexei Dobrohotov 4 months ago

  • Duplicated by Bug #4133: [Regression] [Mod] Abot's Boats no longer works with newer Nightly Builds added

#11 Updated by Alexei Dobrohotov 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF