Project

General

Profile

Bug #4246

OpenMW must take into account armor condition

Added by Vladimir Ulisko 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
12/06/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

OpenMW takes into account weapon condition (code fragment). However, the condition of armor should also be taken into account when calculating the overall armor rating (see here and here for details):

Damaged armor provides less protection against attacks.

To reproduce do this:

  1. player->setUnarmored 5
  2. player->setLightArmor 100
  3. player->setMediumArmor 100
  4. player->setHeavyArmor 100
  5. Wear any armor.
  6. Monitor armor rating in inventory window during battle or casting Disintegrate Armor spell on self.

As result, armor is damaged, but the overall armor rating remains unchanged.

I'm testing OpenMW version 0.43.

Associated revisions

Revision 744859f3 (diff)
Added by Andrei Kortunov 5 months ago

Take in account armor condition in the armor rating calculation (bug #4246)

History

#1 Updated by Andrei Kortunov 5 months ago

  • Status changed from New to Confirmed

Looks like vanilla game uses the "rating * conditionCoeff" formula.
However, Npc::getArmorRating() function in OpenMW does not take armor condition into account. I have no idea, why.

#2 Updated by Andrei Kortunov 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100

#3 Updated by Andrei Kortunov 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF