Project

General

Profile

Bug #4235

Wireframe mode affects local map

Added by Miloslav Číž 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
GUI
Target version:
Start date:
11/30/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

When you toggle wireframe mode (twf in console), the next time local map is re-rendered (for example if you travel a short distance and the cells get reloaded), the wireframe mode corrupts the re-rendered cells, while the rest of the map stays the same (see the picture). This bug doesn't happen in vanilla.

wire.png View (2.14 MB) Miloslav Číž, 11/30/2017 11:18 PM

Associated revisions

Revision 839196e4 (diff)
Added by scrawl . 3 months ago

Force normal polygon mode for the map camera (Fixes #4235)

History

#1 Updated by Grigory Latyshev 6 months ago

Can confirm on Linux, Debian 9.

#2 Updated by Alex Booher 6 months ago

Looks like the orthographic map camera is rendering new snapshots in wireframe mode if it's enabled. The parts of the map that stay the same seem to be parts that haven't been flagged for re-render. If you move far enough away and then go back, it'll be re-rendered in whatever rendering mode you're in.

#3 Updated by Alexei Dobrohotov 6 months ago

  • Target version deleted (openmw-0.44)

#4 Updated by scrawl . 3 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#5 Updated by Andrei Kortunov 3 months ago

  • Assignee set to scrawl .
  • Target version set to openmw-0.44

Also available in: Atom PDF