Project

General

Profile

Bug #4211

FPS drops after minimizing the game during rainy weather

Added by Denis Smirnov 29 days ago. Updated 26 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
11/13/2017
% Done:

100%

Reproducibility:
Have not tried
Operating system:
Windows
Severity:
Normal

Description

When it rains, my OpenMW sometimes suffers from a HUGE slowdown, the latest one was from normal 100+ fps to like 10-15.
Here are some observations (+screenshots with profiler overlay on):
1)screenshot 1,2: the slowdown itself. If I save and reload game now (without closing OpenMw), performance does not change.
2)screenshot 3,4: FPS goes back to normal when the rain ends.
3)screenshot 5,6: if now I load game saved at p.1 (when it's still raining), the performance will still be normal.
4)Performance tends to degrade over time: it has restored to ~100fps at screenshot 6, then I left Openmw running for 20 minutes, and it is already hitting 30.

OpenMW-0.43.0-RC1-win64, no mods except simple texture replacers, view and cell load distance options are all default.
My config is i5-3570 4*3.8Ghz, 16GB RAM, GTX 1080.

1.jpg View (245 KB) Denis Smirnov, 11/13/2017 11:41 PM

2.jpg View (217 KB) Denis Smirnov, 11/13/2017 11:41 PM

3.jpg View (199 KB) Denis Smirnov, 11/13/2017 11:41 PM

4.jpg View (275 KB) Denis Smirnov, 11/13/2017 11:41 PM

5.jpg View (222 KB) Denis Smirnov, 11/13/2017 11:41 PM

6.jpg View (275 KB) Denis Smirnov, 11/13/2017 11:41 PM

screenshot049.png View (1.7 MB) Denis Smirnov, 11/15/2017 11:43 PM

screenshot051.png View (1.31 MB) Denis Smirnov, 11/15/2017 11:43 PM

openmw.zip (304 KB) Denis Smirnov, 11/15/2017 11:48 PM

Associated revisions

Revision 36f4f0ef (diff)
Added by scrawl . 26 days ago

Don't increase simulationTime while the game is minimized (Fixes #4211)

History

#1 Updated by scrawl . 27 days ago

I can't reproduce this. I waited around 20 minutes and the performance was unchanged. Some of that time I was walking around, some of the time standing in place.

1) Are you sure it's really the rain causing it and not something else?
2) Are you using 'distant terrain' or modified cell preloading settings? Did you try with 100% default settings?
3) Can you make a screenshot of all the 'F3' panels (press 'F3' 4 times) and the 'F4' resource stats (while the slowdown is in effect, of course)?
4) Can you upload the output of 'showSceneGraph' command when the game is slow? This should be around 1MB in a zip file (if it's much bigger than that, something is very wrong).

#2 Updated by scrawl . 27 days ago

5) this might be a longshot, but does disabling the water shader remove the slowdown? (could be connected because of the rain ripples effect)

#3 Updated by Denis Smirnov 27 days ago

1) I can't be absolutely sure, but I've repeated the experiment several times in different locations and times of day, and every time the end of the rain was also the end of slowdown (I did wait for 1 hour repeatedly until the weather changed).
I tried one more scenario: when slowdown occurs, going into nearby interior (interior performance is unaffected btw) and back does not change anything, but setting Mark, then doing Divine Intervention to a non-rainy area and then Recall fixes performance.
And finally, there are no signs of performance degradation if I just stand and wait when there is no rain.

2) I didn't use distant land (but it turned out that I actually had 2 cells load distance..oops); as for other settings, I'm not sure - my settings.cfg was somewhat cluttered with legacy parameters from Ogre versions, so I just copied the entire settings-default.cfg and repeated the test. Nothing changed though.
3) Yep, here they are, with slowdown and after it. This 4th level of F3 panel slows things, but the actual FPS without it was 24 vs 400..
4) Uploaded.
5) Disabling water shader is raising the normal FPS to insane 400, but it still drops to the same values after a while.

#4 Updated by Denis Smirnov 27 days ago

I think I've got it. The problem is not just the rain, but also OpenMW window being minimized for some time! Reproduces 100% on my side with such conditions, while waiting with game active or minimizing the game without rain does not cause any troubles.
I see that the game processing itself is paused when minimized, so maybe it's the rain sound causing these problems somehow? It keeps playing even when game is not active.

#5 Updated by scrawl . 26 days ago

  • Subject changed from Massive FPS drop in rainy weather to FPS drops after minimizing the game during rainy weather
  • Status changed from New to Resolved
  • Assignee set to scrawl .
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100

It was not the sound. There was a bug that kept increasing the simulation timer when the game is minimized, and when you resume playing the large time delta makes osgParticle spawn a bazillion particles all at once which causes its particle vector to become large and never shrink again. I've fixed the first issue, but the osgParticle issue can't be fixed without touching OSG or copying a lot of code.

#6 Updated by scrawl . 26 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF