Project

General

Profile

Bug #4210

Some dialogue topics are not highlighted on first encounter

Added by Denis Smirnov 29 days ago. Updated 27 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
GUI
Target version:
Start date:
11/13/2017
% Done:

100%

Reproducibility:
Sometimes
Operating system:
Windows
Severity:
Normal

Description

Sometimes, when taking quests, I noticed that new dialogue topics are not highlighted and are missing from the list in the right part of dialogue window. But, when I click previous topic again, new topic appears in list and is highlighted in dialogue text twice.
Example is attached: at screenshot 1 I select the topic "duties" expecting to get new topic "disappearance of the Dwarves", but it doesn't show up. Then I click "duties" again, and at scrennshot 2 we see new topic highlighted both in latest and previous NPC's answers.
Unfortunately, I don't have any easy steps to reproduce, this situation is pretty random.

1.jpg View (311 KB) Denis Smirnov, 11/13/2017 10:44 PM

2.jpg View (323 KB) Denis Smirnov, 11/13/2017 10:44 PM

Associated revisions

Revision c36d2500 (diff)
Added by scrawl . 27 days ago

Parse dialogue text for keywords after the resultscript runs (Fixes #4210)

History

#1 Updated by Randy Davin 29 days ago

Intended. The dialogue option only highlights after a condition is satisfied. Which is Journal MG_Dwarves => 10.

#2 Updated by scrawl . 29 days ago

  • Assignee set to scrawl .

#3 Updated by Alexei Dobrohotov 28 days ago

  • Category set to GUI

#4 Updated by scrawl . 27 days ago

  • Target version set to openmw-0.44

Also affects the vanilla engine.

To reproduce:

pcjoinfaction "mages guild"
addtopic "duties"

Then talk to Trebonius.

I agree this is a bug and have pushed a fix. There could be a chance though that certain dialogues will rely on the broken behavior and we'll have to revert to it.

#5 Updated by scrawl . 27 days ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF