Project

General

Profile

Bug #4191

"screenshot saved" message also appears in the screenshot image

Added by Randy Davin 3 months ago. Updated 14 days ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
11/06/2017
% Done:

100%

Reproducibility:
Random
Operating system:
Other
Severity:
Normal

Description

The bug does not happen consistently. The only way to test this is by taking many screenshots in various locations(make sure the message disappears first), indoors and outdoors, and then check the screenshots in your openmw folder.

I am not sure what is causing this, even tried with different framerates, different computers with different specs, and different in-game settings.

Although, it seemed that the bug occurs more often(in my case) when screenshot was taken indoors rather than outdoors.

screenshot011.jpg View (267 KB) Randy Davin, 11/07/2017 07:12 AM

screenshot012.jpg View (269 KB) Randy Davin, 11/07/2017 07:12 AM

Associated revisions

Revision b277b838 (diff)
Added by Andrei Kortunov 21 days ago

Display the 'Screenshot saved' message after the screenshot saving (bug #4191)

Revision dba071f8 (diff)
Added by Andrei Kortunov 15 days ago

Remove the 'Screenshot saved' message (bug #4191)

History

#1 Updated by Miloslav Číž 3 months ago

Should we hide the messages in all screenshots? I.e. if you take two consecutive screenshots, the second one will have the message displayed by taking the previous one - if you take many screenshots in a row, you will have messages in them, which could be unwanted. Should we therefore just make all screenshot messages not be rendered in screenshots?

#2 Updated by scrawl . 3 months ago

The randomness here is probably a threading conflict, i.e. the screenshot is randomly taken of either the last frame or the current frame. If you run with OSG_THREADING=SingleThreaded the behavior should be consistent.

Should we hide the messages in all screenshots? I.e. if you take two consecutive screenshots, the second one will have the message displayed by taking the previous one - if you take many screenshots in a row, you will have messages in them, which could be unwanted. Should we therefore just make all screenshot messages not be rendered in screenshots?

Yeah, that sounds like a good idea. Or just remove the message all together - the momentary stutter that taking a screenshot typically produces should be indication enough.

#3 Updated by Randy Davin 3 months ago

Should we therefore just make all screenshot messages not be rendered in screenshots?

If we cannot find a way to hide the message from the screenshot consistently, I think we should just remove it completely. Or if someone prefers to have the message shown, we can make an option to do so in settings.cfg.

#4 Updated by Chris Robinson 3 months ago

I don't see why messages shouldn't be included in the screenshots by default. These messages include dialog subtitles and script messages that inform the player about something, and if a player wants to capture a specific message, not having them in screenshots would be confusing and annoying. Excluding messages from screenshots can also be an issue when we add post-processing shaders since some shaders will apply after the UI is drawn, so getting a screen copy of everything except messages means it will need to be copied before the UI is finished rendering and thus before those post-process shaders are applied.

#5 Updated by Randy Davin 3 months ago

The f11 key, which toggles the presence of HUD could be handy in this situation. Unfortunately, even when I disabled HUD, the screenshot message still shows up in the image after taking screenshot.

#6 Updated by Alexei Dobrohotov 2 months ago

  • Category set to GUI

#7 Updated by Andrei Kortunov 21 days ago

  • Status changed from New to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100
  • Operating system changed from Windows to Other

#8 Updated by Alexei Dobrohotov 14 days ago

  • Status changed from Resolved to Closed

Solution: the message was removed.

Also available in: Atom PDF