Project

General

Profile

Bug #4190

Enchanted clothes changes visibility with Chameleon on equip/unequip

Added by Grigory Latyshev 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Rendering
Target version:
Start date:
11/05/2017
% Done:

100%

Reproducibility:
Have not tried
Operating system:
Linux
Severity:
Normal

Description

When player has equipped echanted clothes and cast Chameleon spell the enchanted clothes randomly change visibility after equip/unequip them.

Screenshots are made with Chameleon 100% for visibility for different cases.

Used OpenMW@master, compiled with Clang3.8, Debian 9

screenshot026.png View (2.69 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot025.png View (2.7 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot027.png View (2.78 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot028.png View (2.66 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot029.png View (2.64 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot031.png View (2.74 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot032.png View (2.75 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot033.png View (2.73 MB) Grigory Latyshev, 11/05/2017 04:20 PM

screenshot034.png View (2.76 MB) Grigory Latyshev, 11/05/2017 04:20 PM

openmw.cfg (38.8 KB) Grigory Latyshev, 11/06/2017 10:04 AM

settings.cfg (14.3 KB) Grigory Latyshev, 11/06/2017 10:04 AM

chameleon_bug.omwsave.xz (1.79 MB) Grigory Latyshev, 11/06/2017 10:04 AM

screenshot008.jpg View (283 KB) Randy Davin, 11/06/2017 02:09 PM

screenshot007.jpg View (284 KB) Randy Davin, 11/06/2017 02:09 PM

Associated revisions

Revision 95b3c118 (diff)
Added by scrawl . 5 months ago

Update shader with a non-color tracking material when equipment is changed during chameleon/invisibility effects (Fixes #4190)

History

#1 Updated by scrawl . 6 months ago

  • Assignee set to scrawl .

#2 Updated by scrawl . 6 months ago

While I can see something potentially wrong with the code that recreates shaders, I can't actually reproduce this bug. I tested player->addspell chameleon_100_unique then repeatedly equipped some enchanted items from the Bloodmoon chest in Toddtest. I also changed 'force shaders' to true or false respectively and played with the color mode of the equipped item, with no difference. Can you post your settings file and an example item ID?

#3 Updated by Grigory Latyshev 6 months ago

Hi,

I attached settings and game save file.

I see this behaviour with "Savior's Hide".

How to reproduce: * load save (you are with 100% chameleon effect) * unequip "Savior's Hide"

#4 Updated by Alexei Dobrohotov 6 months ago

Cannot reproduce this on Windows with the save.

What is your video card? Are you using open source or proprietary video drivers?

#5 Updated by Grigory Latyshev 6 months ago

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
OpenGL Renderer: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)

and
04:00.0 3D controller: NVIDIA Corporation GK208M [GeForce 920M] (rev ff)
OpenGL Renderer: GeForce 920M/PCIe/SSE2

Still present on both cards (optirun is used for NVIDIA). For NVIDIA I used proprietary nvidia linux drivers 375.82

#6 Updated by Randy Davin 6 months ago

I was able to reproduce a similar bug.

1. player->addspell chameleon_100_unique
2. Go to tel fyr, get the cuirass of saviors hide
3. Go to third person
4. Wear the cuirass of saviors hide
5. see screenshot007 for the result
6. if you go to first person and back to third person, the result becomes screenshot008

#7 Updated by Randy Davin 6 months ago

7. If you wear the cuirass of saviors hide in first person, the bug does not occur even if you switch to third person after that.
8. It seems the bug only occurs when you wear the cuirass in third person the first time.

#9 Updated by scrawl . 5 months ago

  • Status changed from New to Resolved

Thanks, I can reproduce this with the cuirass and 'force shaders' enabled.

#10 Updated by scrawl . 5 months ago

  • Target version set to openmw-0.44

#11 Updated by scrawl . 5 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF