Project

General

Profile

Bug #4165

NPCs autoequip new clothing with the same price

Added by Randy Davin about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Game Mechanics
Target version:
Start date:
10/19/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

This may seem trivial, but here is the situation.

Irgola is wearing a "common_shirt_04_b" initially.
I sold a "common_shirt_01" to him.
He instantly wears the sold "common_shirt_01".

The quality(common) is the same but the visuals are different, common_shirt_04_b is better looking than the sack-like "common_shirt_01" which is better suited for peasants and paupers. Irgola is supposedly a successful merchant, it looks strange for him to swap the worst shirt for the better looking one.

This also applies to pants.

And some extra information, if I sell "common_shirt_04_b" to him(the one he wears initially), he swaps that shirt again for the previously sold "common_shirt_01". Irgola seems to be trolling us here..

I understand the engine determines the quality of clothes base on the value of it. So this issue is expected since the afromentioned clothes are of the same value. I was thinking about making a mod that changes the value of the same quality clothes a bit to differentiate them, so that this issue can be solved in openmw.

Note: This is issue is absent in the morrowind engine.

History

#1 Updated by Sean Stach about 1 month ago

Tested and I've found the same issue.

Mechanically speaking the new way is slightly better, as it allows an NPC to change their equipped item even if it's the same value. But, as I feel like the idea of OpenMW is to mirror the mechanics of Morrowind, this should be changed so NPCs don't change to newly received items of the same value.

#2 Updated by Sean Stach about 1 month ago

[[https://github.com/OpenMW/openmw/pull/1512]]

I've hopefully fixed this issue and made a pull request at the above link.

#3 Updated by Andrei Kortunov about 1 month ago

  • Category set to Game Mechanics
  • Status changed from New to Resolved
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100
  • Operating system changed from Windows to Other

#5 Updated by Alexei Dobrohotov about 1 month ago

  • Subject changed from Npc prefer to wear (lower) quality clothes. to NPCs autoequip new clothing with the same price

#6 Updated by Alexei Dobrohotov about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF