Project

General

Profile

Feature #4142

Implement fWereWolfHealth GMST

Added by Vladimir Ulisko 7 months ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Category:
Scripting
Target version:
Start date:
10/05/2017
% Done:

100%

Severity:
Normal

Description

On UESPWiki is written that the maximum health of werewolves should be "twice normal amount", but in OpenMW version 0.42 it is not so.

There are questions:

  1. The commands becomeWerewolf and undoWerewolf don't use some game setting?
  2. I wonder how the current health level will be recalculated when the form is changed?

Associated revisions

Revision e6d9bce5 (diff)
Added by Alexei Dobrohotov 23 days ago

Implement fWerewolfHealth GMST (fixes #4142)

History

#1 Updated by Miroslav Remák 7 months ago

Maybe fWereWolfHealth (2.0 by default) is the health multiplier? This GMST is not used in OpenMW.

#2 Updated by Andrei Kortunov 7 months ago

Can you test an original engine to confirm UESP info?

#3 Updated by Andrei Kortunov 7 months ago

I wonder if Morrowind uses most of fWereWolf* GMST's.

#4 Updated by Andrei Kortunov 7 months ago

Looks like OpenMW uses werewolf GMST's for attributes and skills, but not for dynamic stats (health, magicka and fatigue).
But even if we implement it, we can encounter something like #4115.

#5 Updated by Vladimir Ulisko 6 months ago

UESPWiki shouldn't be wrong. Werewolves must be strong and tenacious (i.e. with high strength and vitality). The high vitality is needed to reduce the effectiveness of offensive spells and "normal" (not silver) weapons against them. Without high vitality, the werewolf's health can be very quickly reach zero if opponent uses a silver weapon.

The fWereWolfHealth GMST should be used by OpenMW as werewolf's health multiplier.

Don't forget that during the transformation, a magical effects that modify maximum of health can be active: Fortify Health and/or Drain Health. When recalculating the maximum health should take the basic maximum health points. It is unclear just how the current health level during the transformation should be recalculated. There are several ways for this. It is possible that it should vary in proportion to the maximum.

As for magicka and fatigue, they shouldn't be affected: they are already correctly recalculated.

#6 Updated by Alexei Dobrohotov 29 days ago

  • Status changed from New to Confirmed

#7 Updated by Alexei Dobrohotov 23 days ago

  • Tracker changed from Bug to Feature
  • Subject changed from The maximum health of werewolves not modified to Implement fWereWolfHealth GMST
  • Status changed from Confirmed to New

#8 Updated by Alexei Dobrohotov 23 days ago

Here's the player werewolf stats function. I imagine that this function and relevant restore/saveSkillsAttributes functions should be renamed and have health functional added. Thankfully they're not used anywhere other than setWerewolf in mechanics manager.

#9 Updated by Alexei Dobrohotov 23 days ago

  • Assignee set to Alexei Dobrohotov

#10 Updated by Alexei Dobrohotov 23 days ago

  • Status changed from New to Resolved
  • Target version set to openmw-0.44

#11 Updated by Alexei Dobrohotov 20 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF