Project

General

Profile

Bug #4136

Enchanted weapons without "ignore normal weapons" flag don't bypass creature "ignore normal weapons" effect

Added by Randy Davin 7 months ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
10/02/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

In openmw, I used "steel blade of heaven" against a hunger, but it has no effect.
In morrowind, the blade is effective and deals damage to the hunger.

As far as I know, enchanted weapons should be effective against magical creatures.?

I checked in CS, it looks like Openmw takes into account the "ignore normal weapon resistances" flag.
If it is unchecked, then Openmw will consider the weapon as normal even though it is enchanted.

Should this issue be fixed by mods or should we replicate vanilla behavior?

If we chose not to replicate vanilla, then this is worthy to be mentioned as a FEATURE. Since now, any custom made enchanted weapons MUST have the "ignore weapon resistance" flag CHECKED in the cs. Otherwise, Morrowind players and OpenMW players will experienced differently when using the same mod, which in turn causes inconsistency.

Capture.JPG View - MCP (155 KB) Randy Davin, 10/26/2017 04:31 PM

Associated revisions

Revision baaf65bc (diff)
Added by Alexei Dobrohotov 22 days ago

Add vanilla enchanted weaponry behavior option, on by default (fixes #4136)

History

#1 Updated by Alexei Dobrohotov 7 months ago

  • Tracker changed from Support to Bug
  • Reproducibility set to Have not tried

Why are you reporting this as a support request?

As per here, if the striking weapon has "magical" or "silver" flag enabled, it isn't affected by resistance/weakness to normal weapons magic effect. Steel blade of heaven doesn't have Magical flag enabled, therefore it's not treated as such, but, for example, steel flamesword does have Magical flag enabled, and it should apply full damage to creatures.

#2 Updated by Alexei Dobrohotov 7 months ago

According to this UESP page, OpenMW actually replicates vanilla behavior in this case. Steel blade of heaven shouldn't damage hungers in the original engine without mods.

#3 Updated by Randy Davin 7 months ago

Alexei Dobrohotov wrote:

Why are you reporting this as a support request?

Im sorry, English is not my first language, I just think this issue is not really a bug, because I prefer OpenMw mechanics but also thought we can try implement morrowind mechanics.

Actually I tested this issue using openmw and morrowind without any mods. Both behaved differently regarding this issue.

This issue is not really serious, I was just curious on developers thoughts. I apologize.

#4 Updated by Alexei Dobrohotov 7 months ago

  • Category set to Game Mechanics

#5 Updated by Randy Davin 6 months ago

#6 Updated by Alexei Dobrohotov 6 months ago

  • Subject changed from Openmw enchanted weapon behavior different from morrowind to Enchanted weapons without "ignore normal weapons" flag don't bypass creature "ignore normal weapons" effect
  • Status changed from New to Confirmed
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from Windows to Other

Yep.

I'm not sure vanilla behavior should be replicated. Well, maybe this should be a toggle, with vanilla behavior used by default.

#7 Updated by Alexei Dobrohotov 23 days ago

  • Assignee set to Alexei Dobrohotov

#8 Updated by Alexei Dobrohotov 23 days ago

  • Status changed from Confirmed to Resolved
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100

#9 Updated by Alexei Dobrohotov 20 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF