Project

General

Profile

Bug #4135

Reflecting an absorb spell different from vanilla

Added by Randy Davin 7 months ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
10/01/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Tested with absorb health spell, have not tried other absorb spells.

In openmw, reflected absorb health is lethal to the original caster, whereas in morrowind, reflected absorb health has no effect to the original caster because the spell effects cancel each other.

To make it simpler, when reflected, the caster absorbs his own health but also heals himself, therefore making the spell practically useless.

There are several choices here, either:

1.Making the reflected absorb spell, absorb the attribute of the original caster, but not transferring the absorbed attribute to anybody.(lethal)
2.Making the reflected absorb spell, absorb the attribute of the original caster and transfers it to the reflector.(lethal)
3.Making the reflected absorb spell, absorb the attribute of the original caster and transfers it back to the original caster, whereas the reflector do not benefit nor suffer from anything.(non-lethal)(vanilla implementation)

Capture.JPG View - MCP (130 KB) Randy Davin, 10/26/2017 06:57 PM

Associated revisions

Revision 2d119e83 (diff)
Added by Alexei Dobrohotov 26 days ago

Add vanilla absorb attribute behavior option, on by default (Fixes #4135)

History

#1 Updated by Alexei Dobrohotov 7 months ago

  • Tracker changed from Support to Bug
  • Reproducibility set to Have not tried

Actually OpenMW behaves like MCP, and logically the actor with Reflect should receive a percentage of absorbed health from the caster. I'm inclined to reject this as intended behavior.

#2 Updated by Randy Davin 7 months ago

Alexei Dobrohotov wrote:

actor with Reflect should receive a percentage of absorbed health from the caster

Im curious about this, is there a reason for making it only "receive a percentage"?. I assume you mean its not 100% percent, is this a new feature? It looks like OpenMw reflect has a magnitude of reflection hardcoded. Since magnitude of reflect in spellmaking refers to the chance.

#3 Updated by Alexei Dobrohotov 7 months ago

Sorry, I interpreted the code wrong. Yes, magnitude of Reflect magic effect affects the chance of reflecting 100% of the spell.

#4 Updated by Alexei Dobrohotov 7 months ago

  • Category set to Game Mechanics

#5 Updated by Randy Davin 6 months ago

#6 Updated by Alexei Dobrohotov 6 months ago

  • Status changed from New to Rejected

As per MCP description, that is Hrnchamd's reverse-engineering results, the original behavior is bugged:

When you cast an absorb spell and it's reflected, you absorb from yourself and the enemy gets nothing. Apparently not as intended.

So OpenMW behavior doesn't need to be changed.

#7 Updated by AnyOldName 3 4 months ago

  • Subject changed from Absorb spell different from vanilla to Reflecting an absorb spell different from vanilla
  • Status changed from Rejected to New

There seems to be a lot of debate whether the designers of Morrowind intended to have the behaviour of the original engine or MCP. I'm un-rejecting this issue and marking it as new again so that either someone with some authority can prove one way or the other which behaviour was intended, and if the debate cannot be settled, someone can implement an option to have either behaviour.

Associated forum thread: https://forum.openmw.org/viewtopic.php?f=3&t=4831

#8 Updated by Alexei Dobrohotov 27 days ago

  • Status changed from New to Resolved
  • Assignee set to Alexei Dobrohotov
  • Target version set to openmw-0.44
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from Windows to Other

I added a setting to control the behavior and will submit a pull request soon. By default it's the vanilla-like caster-absorbs-from-themselves.

#9 Updated by Alexei Dobrohotov 20 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF