Project

General

Profile

Bug #4134

Battle music behaves different than vanilla

Added by R C 8 months ago. Updated 26 days ago.

Status:
Closed
Priority:
Normal
Category:
Sound/Other Media
Target version:
Start date:
09/30/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

In vanilla, if you went into the Data Files folder and deleted the tracks in the Music/Battle folder, the game would play the next available track in the Explore folder.

In OpenMW, deleting tracks within the Music/Battle makes the game go silent for the duration of the battle, after which the next Explore track will play.

Associated revisions

Revision 9073e4d4 (diff)
Added by Alexei Dobrohotov 29 days ago

Initialize playlist file list in playPlaylist (fixes #4134)

History

#1 Updated by Andrei Kortunov 8 months ago

IMO, OpenMW behaviour is more consistent. Why should an engine ever play Explore music in combat? And why should a player delete tracks from Battle folder?

If you want to use Explore tracks instead of Battle ones, you can just replace tracks in the Battle folder by tracks from the Explore folder, without any engine hacks.

#2 Updated by scrawl . 8 months ago

IMO, OpenMW behaviour is more consistent. Why should an engine ever play Explore music in combat? And why should a player delete tracks from Battle folder?

Just taking a guess: Probably because they don't like the interruption of the explore music whenever an enemy is detected, even if it's just a pesky scrib where the battle lasts all of 2 seconds.

If you want to use Explore tracks instead of Battle ones, you can just replace tracks in the Battle folder by tracks from the Explore folder, without any engine hacks.

That just causes the music to restart on every Battle<->Explore change for no reason, then.

#3 Updated by Chris Robinson 8 months ago

IMO, we shouldn't suggest deleting or altering vanilla files to mod the game. If a user wants to then it's their prerogative, but I think any desirable behavior should be accomplished by overriding vanilla files with something different so that the originals are untouched.

The way mods like Morrowind Acoustic Overhaul and Better Music System handle this is by replacing the default explore and battle music tracks with silence and utilizing the MCP option to prevent playlist changes from interrupting scripted music (where scripts then control what music is played when). So the script will play a song, and regardless of going in and out of battle that scripted song continues to play until the script says otherwise, and when that song ends it goes to silence until the script triggers another song to play.

I had played around with adding a similar settings option to OpenMW, but I hadn't worked out all the kinks by the time I started to feel it was a bit unnecessary since we'll probably be adding more powerful playlist capabilities post-1.0. Also, only BTB's stripped-down version of BMS actually works with OpenMW, as both MAO's music module and the original BMS require MWSE functionality, which further limits the usefulness of such an option.

In this particular case, since the idea is to simply not play combat music, we could add a 'no battle music' settings option which prevents changing to the Battle playlist. Although given the primitive music handling, I'm not sure it'd be that good without a mod to improve it. A user could just as well set the music volume to 0 and play their own music in a background app to get the same effect (and have more control over which songs can play, instead of just what's in the Explore directory).

#4 Updated by Alexei Dobrohotov 8 months ago

  • Category set to Sound/Other Media

#5 Updated by Alexei Dobrohotov 7 months ago

  • Subject changed from OpenMW treats Battle Music differently than vanilla Morrowind to Battle music behaves different than vanilla
  • Status changed from New to Confirmed
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from MacOS to Other

#6 Updated by Andrei Kortunov 6 months ago

That just causes the music to restart on every Battle<->Explore change for no reason, then.

The same thing in vanilla game: there is an Explore->Explore transition (the music restart) after combat. Such behaviour is a bit inconsistent.

I'd prefer to implement the 'no battle music' setting.

So what we may to do:
1. Replicate vanilla behaviour bug-to-bug
2. Replicate vanilla behaviour partially: if the Combat playlist is empty, ignore both Explore->Combat and Combat->Explore transitions
3. Provide the 'no battle music' setting.

Which option should we choose?

#7 Updated by Chris Robinson 6 months ago

Andrei Kortunov wrote:

So what we may to do:
1. Replicate vanilla behaviour bug-to-bug
2. Replicate vanilla behaviour partially: if the Combat playlist is empty, ignore both Explore->Combat and Combat->Explore transitions
3. Provide the 'no battle music' setting.

Which option should we choose?

If anything, I'd say 3. But even that may be unnecessary since, like I mentioned, a user could just set the in-game music volume to 0 and play their desired music in a separate app (which gives more flexibility in what to play).

#8 Updated by R C 6 months ago

Chris Robinson wrote:

3. Provide the 'no battle music' setting.

Which option should we choose?

If anything, I'd say 3. But even that may be unnecessary since, like I mentioned, a user could just set the in-game music volume to 0 and play their desired music in a separate app (which gives more flexibility in what to play).

Here's my issue with this, however: opening a separate app with OpenMW running causes a dip in performance (at least for me).

Not all PCs are modern enough to run too many apps at once and a music-playing application running at the same time as OpenMW will cause lags, performance drops and drain the battery faster.

Also, having to use an external music player is rather impractical. If I'm not mistaken, some areas such as Cavern of the Incarnate have unique music - If I were to use an external application to control my music, I would have to create a specific morrowind playlist, and miss out on area-specific music that the game and certain mods add.

If it can be achieved without having to use an external application to do so, I'd say it's worth doing...

#9 Updated by Alexei Dobrohotov 30 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Alexei Dobrohotov
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100

#10 Updated by Alexei Dobrohotov 26 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF