Project

General

Profile

Bug #4131

Pickpocketing behaviour is different from vanilla

Added by Andrei Kortunov 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
09/30/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

How it works in Morrowind:
1. If you try to steal an item and pickpocked failed, a "Pickpocket" crime with iCrimePickPocket bounty will be reported.
2. Even in this case an engine checks for pickpocketing on window closing, so a second "Pickpocket" crime can be reported.
3. If a target is knocked down, and a player was caught on inventory closing, a "Pickpocket" crime with iCrimePickPocket bounty will be reported. Otherwise a "Theft" crime will be reported (a bounty depends on item value).
4. If a crime was reported, unconscious actors do not become hostile (since they can not see the crime and report about it).

How it works in OpenMW:
1. If you try to steal an item and pickpocketing was failed, a "Theft" will be reported (a bounty depends on item value).
2. An engine just disables a pickpocketing window without check (but maybe this behaviour is more consistent).
3. If a target is knocked down, you can just take any item from it without any bounty.
4. If a crime was reported, unconscious actors become hostile too and still can report about crime.

Note: you can loot only friendy unconscious actors, so you can use a "modcurrentfatigue" console command to reproduce this bug.

Associated revisions

Revision 302e3c8b
Added by scrawl . 2 months ago

Merge pull request #1486 from akortunov/pickpocketfix

Fix some issues with pickpocketing (bug #4131)

History

#1 Updated by Andrei Kortunov 2 months ago

  • Description updated (diff)

#2 Updated by Andrei Kortunov 2 months ago

  • Description updated (diff)

#3 Updated by Andrei Kortunov 2 months ago

  • Status changed from New to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

#4 Updated by Alexei Dobrohotov 2 months ago

  • Subject changed from Pickpocketing behaviour is defferent from vanilla to Pickpocketing behaviour is different from vanilla

#5 Updated by Alexei Dobrohotov 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF