Project

General

Profile

Bug #4122

Swim animation should not be interrupted during underwater attack

Added by Andrei Kortunov 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Low
Category:
Animation
Target version:
Start date:
09/22/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Just go underwater and press an "Attack" button.
In vanilla game a swim idle animation is still played for legs, in OpenMW a swim animation stops, and character's legs are not moving.

Associated revisions

Revision dea7d0be (diff)
Added by Andrei Kortunov 5 months ago

Do not interrupt swim and sneak idle animations during attack (bug #4122)

History

#1 Updated by Andrei Kortunov 7 months ago

Note: you even do not need to draw your weapon. Just hold an attack button underwater in the 3d-person view.

#2 Updated by Alexei Dobrohotov 7 months ago

  • Status changed from New to Confirmed
  • Operating system changed from Linux to Other

#3 Updated by Alexei Dobrohotov 6 months ago

  • Target version set to openmw-1.0

#4 Updated by Andrei Kortunov 5 months ago

Looks like commit 67bd882bc784dfe258d370535010c38cd0bdeb64 causes this bug. We should look for a better solution.

#5 Updated by Andrei Kortunov 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version changed from openmw-1.0 to openmw-0.44
  • % Done changed from 0 to 100

#6 Updated by Andrei Kortunov 5 months ago

  • Status changed from Resolved to Closed

Applied in the changeset dea7d0b.

Also available in: Atom PDF