Project

General

Profile

Bug #4113

'Resolution not supported in fullscreen' message is inconvenient

Added by Dark Locq 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
General
Target version:
Start date:
09/18/2017
% Done:

100%

Reproducibility:
Sometimes
Operating system:
Other
Severity:
Normal

Description

Conditions:
  • Start game
  • Set resolution to 1344 x 756 (16 : 9)
  • Go full-screen, play the game a while, change to windowed mode.
  • Quit and restart.
  • Try to go full-screen again

Result: You'll sometimes be told that your resolution does not support full-screen mode. If you change it to 1344 x 756 again, the window will slightly adjust in size, then you can do full screen.

I "caught it in the act" by checking the Graphics tab in the launcher, and found it set to a custom resolution of 1344 x 734, which isn't even a proper option.

This is intermittent, and I don't know what triggers it. It happened to be me today (for probably the 50th time or so), and I attempted to repro it, but upon restart it was back in 1344 x 756 as it should be.

There's no error message, and it doesn't affect anything at all other than having to manually put it back in 1344 x 756 before being able to full-screen the game again. Sometimes the problem happens multiple times per day, but I cannot think of anything I'm doing differently between restarts that work right and those that don't.

Associated revisions

Revision 5b10e312 (diff)
Added by scrawl . 2 months ago

Use first resolution in fullscreen if current is not supported (Fixes #4113)

History

#1 Updated by scrawl . 3 months ago

  • Category changed from Launcher to General
  • Status changed from New to Confirmed
  • Operating system changed from MacOS to Other

Thanks for reporting this bug. This behavior always bothered me a lot, but for some reason I never thought to do something about it.

Most window managers will automatically change the size of windows to fit the available viewport. For example, if your screen is 1344 x 756, the taskbar (and/or the window title) fills 22 pixels, that leaves you with 1344 x 734 of space and the window will be resized to that effect. This resizing is useful, but makes it more difficult to re-enter full screen with OpenMW. You're left with:
  • Try to change the window back to its fullscreen size (hoping the window manager won't attempt to be smart and resize it again), then go fullscreen
  • Select a smaller, valid fullscreen resolution (e.g. 800x600), go full-screen, then change back to the proper resolution

The first option doesn't always work, and the second option can be annoying (need to sit through 2 black screens as your monitor changes modes, and hope you're not affected by #884 where choosing a non-native fullscreen resolution totally breaks the output).

I think the cleanest way to handle this would be to somehow decouple fullscreen and windowed resolutions. They serve different purposes, anyway; the windowed resolution affects the size of the viewport, whereas a fullscreen resolution determines the detail/resolution with the whole screen being filled in any case. The default behavior when entering fullscreen should be to use the native monitor resolution, and exiting fullscreen should go back to a resolution that's managable and doesn't fill the entire screen. Making it harder to use non-native resolutions (whether by accident or not) should also reduce the impact of #884 a little.

Pending a discussion on how exactly said decoupling should be achieved, a much simpler solution (purely for what's in the OP) would be to change to a 'nearest match' resolution when going fullscreen (i.e. going fullscreen from 1344 x 734 would use 1344 x 756, 800x500 would use 800x600, etc.), or fall back to the native resolution if the requested resolution is not valid in fullscreen.

#2 Updated by Dark Locq 3 months ago

Well, another issue – which may be a bug or intentional behavior – is that (in Mac OS X, anyway) if you have a huge monitor you cannot actually playably run the game at that resolution in full-screen mode, because the GUI interface elements (inventory icons, etc.) do not scale "right". They simply get smaller and smaller until they're too tiny to make out or effectively use. The 1344 x 756 I've been using is much less than my monitor is capable of. So, "The default behavior when entering fullscreen should be to use the native monitor resolution" wouldn't work for many of us. To me the ideal default behavior is to use the resolution I told it to use (windowed or full-screen), and never any other resolution unless/until I pick one manually (in game, in the Graphics pane in the launcher, or by manually editing the config file).

Kinda wish it would also do multiple monitors, but I guess that might tax the CPU too much (and it wouldn't be practical except with 3, since the division between 2 monitors would be right where the crosshair is).

#3 Updated by Andrei Kortunov 3 months ago

They simply get smaller and smaller until they're too tiny to make out or effectively use.

Did you try to change a "scaling factor" setting in the GUI section in settings.cfg?

#4 Updated by scrawl . 2 months ago

  • Subject changed from Screen resolution not always saved if you restart out of full-screen mode to 'Resolution not supported in fullscreen' message is inconvenient
  • Status changed from Confirmed to Resolved
  • Assignee set to scrawl .
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

never thought to do something about it.

Hm.. actually we had a partial 'fix' already: the game uses the last selected item in the resolution list when switching to fullscreen, not the actual current resolution. But that doesn't work if you've restarted since changing size, as described in OP.

The 'resolution not supported in fullscreen' message has now been removed and instead the game falls back to the first resolution from the list.

#5 Updated by scrawl . 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF