Project

General

Profile

Bug #4105

birthsign generation menu does not show full details

Added by openmw hardcore about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
09/15/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Having many abilities or powers in the birthsign menu, will not show the rest of the abilities or powers. The scroll bar is needed here.

Look picture for details:

screenshot003.jpg View (300 KB) openmw hardcore, 09/15/2017 05:15 AM

screenshot004.jpg View (302 KB) openmw hardcore, 09/15/2017 05:15 AM

screenshot005.jpg View (298 KB) openmw hardcore, 09/15/2017 05:16 AM

screenshot013.png View - Birthsign menu at 800x600 with vanilla assets (434 KB) Alexei Dobrohotov, 09/16/2017 06:23 PM

vanilla.PNG View - Birthsign menu at 800x600 (original engine) (693 KB) Alexei Dobrohotov, 09/16/2017 06:33 PM

Снимок.PNG View - Overflowing list of effects (vanilla engine) (251 KB) Alexei Dobrohotov, 09/16/2017 06:48 PM

Associated revisions

Revision 3fb3c4c2 (diff)
Added by Andrei Kortunov about 1 month ago

Add scrollbar to a birth effect lists (bug #4105)

Revision 277b57b2
Added by scrawl . about 1 month ago

Merge pull request #1457 from akortunov/guifixes

[Feedback needed] Add scrollbar to a birth effect lists (bug #4105)

History

#1 Updated by scrawl . about 1 month ago

Can't imagine we wouldn't have noticed that before so it's probably caused by one or more of your mods. Is it just me or does the font seem larger than normal?

#2 Updated by scrawl . about 1 month ago

Regardless, yes - a scrollbar is required to deal with the possibility of mods introducing more spell effects for a birthsign.

#3 Updated by Alexei Dobrohotov about 1 month ago

Nope, it's actually smaller (well, thinner). And looks like it's Pelagiad font.
I'll try to add more things to a birthsign and see what vanilla does in this case.

(800x600 is the resolution of op's screenshots)

#4 Updated by Alexei Dobrohotov about 1 month ago

I'm not quite sure what I expected.

#5 Updated by openmw hardcore about 1 month ago

Yes it is pelagiad font.
I was making a mod that adds more abilities and spells for birthsigns. The birthsign menu doesnt show all of it.

#6 Updated by Alexei Dobrohotov about 1 month ago

  • Category set to GUI

#7 Updated by Andrei Kortunov about 1 month ago

  • Status changed from New to In Progress
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 50
  • Operating system changed from Windows to Other

#8 Updated by Andrei Kortunov about 1 month ago

  • Status changed from In Progress to Confirmed
  • Assignee deleted (Andrei Kortunov)
  • Target version deleted (openmw-0.43)

Should work now.
The only know issue: a mouse scroll does not work for effects list for now.

#9 Updated by Andrei Kortunov about 1 month ago

know

Known, I mean.

#10 Updated by scrawl . about 1 month ago

  • Status changed from Confirmed to Closed
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 50 to 100

Mouse scrolling was not a necessary requirement.

#11 Updated by Alexei Dobrohotov about 1 month ago

Might be worthy to be included in Features.

Also available in: Atom PDF