Project

General

Profile

Bug #4104

Cycling through weapons does not skip broken ones

Added by openmw hardcore about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
09/14/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Bug or Feature, not sure.
Steps to reproduce:
1. equip a weapon
2. have at least 2 broken weapons and 1 good conditioned weapon
3. press the [ or ] key to cycle
4. you cant cycle to the good conditioned weapon.

What it should do is skip the broken weapons, and go to the next good one.

This "feature" is good, because if your current weapon is broken during combat, you can easily switch to a good weapon using the bracket key, and do not need to reopen the inventory and check which weapon is still in good condition to be used. Quite troublesome when you have lots of (broken) weapons in the inventory.

V0.42.

Associated revisions

Revision 10a0136b (diff)
Added by Andrei Kortunov about 1 month ago

Cycle only through weapons which can be equipped by player (bug #4104)

History

#1 Updated by Alexei Dobrohotov about 1 month ago

  • Category set to Game Mechanics

Weapon cycling using [ and ] as the default hotkeys for "Previous" and "Next Weapon" was implemented more than two and a half years ago and included in releases since OpenMW 0.35.0. Please clarify what do you mean. FWIW, broken weapons (that have 0 condition) cannot be equipped.

#2 Updated by openmw hardcore about 1 month ago

Alexei Dobrohotov wrote:

Weapon cycling using [ and ] as the default hotkeys for "Previous" and "Next Weapon" was implemented more than two and a half years ago and included in releases since OpenMW 0.35.0. Please clarify what do you mean. FWIW, broken weapons (that have 0 condition) cannot be equipped.

If a weapon is broken in the inventory, it should be skipped when cycling using the [ and ] keys. The problem now is that, you cannot cycle even if you have another good conditioned weapon in the inventory.

Unless ALL your weapons in your inventory is broken, then this is not possible.

The issue now is, if you have, say, 99 broken weapons and 1 good weapon in your inventory, you cannot cycle to the next good weapon.

1. Equip a weapon
2. Make sure you have some broken weapons, but only 1 good conditioned weapon IN THE INVENTORY (not equipped).
3. Try to cycle
4. You cannot cycle to the unequipped good weapon.

#3 Updated by scrawl . about 1 month ago

  • Subject changed from Cycling through weapons using the bracket key is not functioning to Cycling through weapons does not skip broken ones

#4 Updated by Goody goody Yum yum about 1 month ago

  • File bug4104.patch added

#5 Updated by scrawl . about 1 month ago

  • File deleted (bug4104.patch)

#6 Updated by Andrei Kortunov about 1 month ago

  • Status changed from New to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100
  • Operating system changed from Windows to Other

#7 Updated by Andrei Kortunov about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF