Project

General

Profile

Bug #4102

IndyBank script fails to compile multi-line messagebox

Added by Arakhor Vorac 7 days ago. Updated 5 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Scripting
Target version:
-
Start date:
09/13/2017
% Done:

0%

Reproducibility:
Always
Operating system:
Windows
Severity:
Normal

Description

The IndyBank mod uses a topic option to give you an account summary. Whilst the rest of the mod appears to work correctly, including paying out interest and giving you a bank statement as a document, the "account status" topic doesn't work properly. It has a bunch of script stuff in the Result box, listed below, which simply doesn't show up.

Account Status result box:

set YourGold to "Player"->GetItemCount Gold_001
MessageBox " Membership Level: %.0f
Account Balance: %.0f
Your Gold: %.0f
Interest Rate: %.3f
Service Charge Rate: %.3f
Total Service Charges: %.0f
Total Interest Earned: %.0f "
Membership BankAccount YourGold InterestRate ServiceRate TotalServiceCharges TotalInterestEarned

if ( LoanAmount > 0 )
MessageBox " Loan: %.0f
Loan Payment Amount: %.0f" LoanAmount LoanPayment
endif

For reference, this is the (working) bank statement:

<DIV ALIGN="LEFT"><FONT COLOR="000000" SIZE="3" FACE="Magic Cards">
Bank Statement for %bank_s_Month.%bank_s_Day.%bank_s_Year 3E<BR>
<BR>
Name: %PCName<BR>
Membership Level: %bank_s_MemberShip<BR>
Balance: %bank_s_Account<BR>
Total Interest Earned: %bank_s_TotalInterest<BR>
Total Service Charges Deducted: %bank_s_TotalService<BR>
<BR>
Loan Information:<BR>
<BR>
Loan Remaining: %bank_s_LoanAmount<BR>
Loan Payment Due: %bank_s_LoanPayment<BR>
Loan Payments Begin: %bank_s_LoanDayCounter Days<BR>
<BR>
<DIV ALIGN="CENTER">
<IMG SRC="bankseal1.tga" WIDTH="64" HEIGHT="64"><BR>
- Issued by the Bank of Vvardenfell
<p>

OpenMW IndyBank.jpg View (223 KB) Arakhor Vorac, 09/13/2017 04:17 PM

Original MW IndyBank.jpg View (179 KB) Arakhor Vorac, 09/13/2017 04:17 PM

OpenMW IndyBank - Edit.jpg View (260 KB) Arakhor Vorac, 09/13/2017 06:06 PM


Related issues

Duplicates OpenMW - Bug #3836: Script fails to compile when command argument contains "\n" Confirmed 04/22/2017

History

#1 Updated by scrawl . 7 days ago

Look at your openmw.log. There should be a script compile error in there (I imagine due to the multi-line messagebox statement that's not supported)

#2 Updated by Arakhor Vorac 7 days ago

There is, yes. What can be done about that?

error [dialogue script] line 3, column 1 ()
incomplete string or name
error [dialogue script] line 3, column 1 ()
syntax error
Warning: compiling failed (dialogue script)

set YourGold to "Player"->GetItemCount Gold_001
MessageBox " Membership Level: %.0f
Account Balance: %.0f
Your Gold: %.0f
Interest Rate: %.3f
Service Charge Rate: %.3f
Total Service Charges: %.0f
Total Interest Earned: %.0f " Membership BankAccount YourGold InterestRate ServiceRate TotalServiceCharges TotalInterestEarned
if ( LoanAmount > 0 )
MessageBox " Loan: %.0f
Loan Payment Amount: %.0f" LoanAmount LoanPayment
endif

;set YourGold to "Player"->GetItemCount Gold_001
;MessageBox " Membership Level: %.0f " Membership
;MessageBox " Account Balance: %.0f " BankAccount
;MessageBox " Your Gold: %.0f " YourGold
;MessageBox " Interest Rate: %.3f " InterestRate
;MessageBox " Service Charge Rate: %.3f " ServiceRate
;MessageBox " Total Service Charges: %.0f " TotalServiceCharges
;MessageBox " Total Interest Earned: %.0f " TotalInterestEarned
;if ( LoanAmount > 0 )
; MessageBox " Loan: %.0f " LoanAmount
; MessageBox " Loan Payment Amount: %.0f" LoanPayment
;endif

#3 Updated by scrawl . 7 days ago

  • Subject changed from Message box display using script variables to Multi-line messagebox script instructions are not supported
  • Category set to Scripting

#4 Updated by David Walley 7 days ago

Temporary Fix (pending the addition of support for Multi-line messagebox script instructions)

Comment out the uncommented section (approx first 12 lines)
Uncomment the commented section (approx last 12 lines)

This reverts to single line message box

Will add this to Mod Compatibility testing results

#5 Updated by Arakhor Vorac 6 days ago

Commenting out the first block didn't work for me, but deleting it did.

Having only the single-line message boxes produces no log errors and looks very similar to the 'intended' display.

#6 Updated by scrawl . 5 days ago

  • Status changed from New to Rejected

Duplicate of #3836

#7 Updated by scrawl . 5 days ago

  • Duplicates Bug #3836: Script fails to compile when command argument contains "\n" added

#8 Updated by scrawl . 5 days ago

  • Subject changed from Multi-line messagebox script instructions are not supported to IndyBank script fails to compile multi-line messagebox

Also available in: Atom PDF