Project

General

Profile

Bug #4076

Disposition bar is not updated when "goodbye" selected in dialogue

Added by openmw hardcore 18 days ago. Updated 14 days ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
09/05/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

when using ModDisposition and Goodbye on the dialogue result, the npc disposition only updates after you close/open the dialogue window in-game.

vanilla MW updates the disposition instantly without needing to close/open the dialogue window

History

#1 Updated by Dark Locq 14 days ago

This might end up affecting the results of Intimidate. I've notice that if you do a successful Intimidate, the Disposition shoots up immediately, then when you close and reopen dialogue, the Dispo will have dropped to below what it was the before any Intimidation. I assumed this was intentional – the NPC is going along with you to get you to quit intimidating them, but afterward will end up liking you even less because you were a jerk. I don't have MS Windows, so I'm not sure what the Bethesda behavior actually is.

If Dispo effects are all changed to happen immediately, it might end up being a side effect that a successful Intimidate would then raise and immediately re-lower the Dispo all at once.

#2 Updated by openmw hardcore 14 days ago

Dark Locq wrote:

This might end up affecting the results of Intimidate. I've notice that if you do a successful Intimidate, the Disposition shoots up immediately, then when you close and reopen dialogue, the Dispo will have dropped to below what it was the before any Intimidation. I assumed this was intentional – the NPC is going along with you to get you to quit intimidating them, but afterward will end up liking you even less because you were a jerk. I don't have MS Windows, so I'm not sure what the Bethesda behavior actually is.

If Dispo effects are all changed to happen immediately, it might end up being a side effect that a successful Intimidate would then raise and immediately re-lower the Dispo all at once.

nothing to do with intimidate.
what i meant was, say you create a topic in the dialogue(http://oi67.tinypic.com/k3ukuv.jpg) and the result is;

Moddisposition, -30
Goodbye

Clicking on the topic in-game, the goodbye choice will appear but will not reduce the npc disposition by 30
Only after clicking goodbye and reopening the dialogue with the npc, then the disposition is updated.
Vanilla morrowind updates instantly without needing to close and open the dialogue window.

Although I think this is really a minor and negligible issue, since you cant do anything in the dialogue other than clicking the "goodbye" option. but still..

#3 Updated by Andrei Kortunov 14 days ago

  • Subject changed from Disposition not updated to Disposition bar is not updated when "goodbye" selected in dialogue
  • Status changed from New to Confirmed
  • Operating system changed from Windows to Other

#4 Updated by Andrei Kortunov 14 days ago

  • Severity changed from Major to Normal

#5 Updated by Andrei Kortunov 14 days ago

  • Category set to GUI

Actually, disposition is updated properly in your case.
An engine just does not update disposition bar, because dialogue widget is blocked in the "goodbye" mode.

#6 Updated by Andrei Kortunov 14 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • % Done changed from 0 to 100

#7 Updated by Alexei Dobrohotov 14 days ago

  • Target version set to openmw-0.43

#8 Updated by Alexei Dobrohotov 14 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF