Project

General

Profile

Bug #4061

Scripts error on special token included in name

Added by Loriel 2 5 months ago. Updated 10 days ago.

Status:
Closed
Priority:
Normal
Category:
Scripting
Target version:
Start date:
09/02/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Unlike vanilla, OpenMW errors on "." included in script names.
Many of Emma's companion scripts include "." in script name, used as sub-versioning. For example, Laura includes the script 11AA_LauraScript7.5, which generates the error "Unexpected Floating Point Value" and breaks the mod.

Associated revisions

Revision 2dff3aab (diff)
Added by Marc Zinnschlag 10 days ago

allow . and - in the name part of a begin script statement, but not at the beginning of a name. Fixes #4061

History

#1 Updated by Marc Zinnschlag 5 months ago

  • Category set to Scripting
  • Target version set to openmw-0.43

#2 Updated by scrawl . 4 months ago

  • Target version changed from openmw-0.43 to openmw-1.0

#3 Updated by Alexei Dobrohotov 4 months ago

  • Status changed from New to Confirmed

#4 Updated by Andrei Kortunov 19 days ago

  • Subject changed from Scripts error on "." included in name to Scripts error on special token included in name

Some other special tokens are inacceptable too. For example, a Rhizoma mod has the "01_Rz_neuvazhay-koryto2" script, which failed to compile because of hyphen ib the name.

#5 Updated by rot tor 12 days ago

"01_Rz_neuvazhay-koryto2" script, which failed to compile because of hyphen ib the name

To clarify, can you confirm that this is an issue with the openMW CS/compiler and not the engine (or dialogue results compiler) itself? The use of hyphens/dashes in script IDs was fixed before in #677

#6 Updated by Marc Zinnschlag 10 days ago

  • Status changed from Confirmed to Closed
  • Assignee set to Marc Zinnschlag
  • Target version changed from openmw-1.0 to openmw-0.44
  • % Done changed from 0 to 100

Added special case implementation for . and - characters

Also available in: Atom PDF