Project

General

Profile

Bug #4056

Draw animation should not be played when player equips a new weapon

Added by Andrei Kortunov about 2 months ago. Updated 28 days ago.

Status:
Closed
Priority:
Normal
Category:
Animation
Target version:
Start date:
09/01/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

Morrowind does not play draw animation when equip a new weapon, OpenMW plays animation, but only when a new weapon has a type, different from previous one.

Our current behaviour can lead to bugs. For example, "Item Weapon * Up" sound played twice when you cycle weapon.
First sound comes from ActionEquip, second one comes from CharacterController::updateWeaponState() when player draws a new weapon.

Notes:
1. If we prefer OpenMW behaviour, we should play animation with every weapon change, and fix the sound issue.
2. Looks like Mororwind handles Hand-To-Hand differently from weapons: if you unequip your weapon, a Hand-To-Hand draw animation will be played.

Tested with upstream git version.

Associated revisions

Revision 5da532a3 (diff)
Added by Andrei Kortunov 28 days ago

Do not play draw weapon animation when equip a new weapon (bug #4056)

History

#1 Updated by Alexei Dobrohotov about 1 month ago

  • Status changed from New to Confirmed

#2 Updated by Andrei Kortunov 28 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

#3 Updated by Andrei Kortunov 28 days ago

  • Status changed from Resolved to Closed

Applied in the 5da532a commit.

Also available in: Atom PDF