Project

General

Profile

Bug #4037

OpenMW-CS: New greetings do not work in-game.

Added by DestinedTo Die 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Editor
Target version:
Start date:
08/23/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Windows
Severity:
Normal

Description

I tried to make a new greeting, but it never shows up in-game. When I do the exact same thing in the Morrowind CS, it immediately works without issue. I've uploaded an example .owmaddon of this where it doesn't work. Go to Seyda Neen and cross the bridge towards the swamp. You'll find an argonian who should greet you with "You should see this!" but he doesn't. Analogous situation works fine with Morrowind CS.

DialogueGreeting.omwaddon (23.9 KB) DestinedTo Die, 08/23/2017 08:10 PM

DialogueTest.ESP (1.9 KB) DestinedTo Die, 08/24/2017 01:43 AM

History

#1 Updated by Kyle Cooley 3 months ago

Seems that Argonian is headless as well! Could you upload the esm file that works?

#2 Updated by DestinedTo Die 3 months ago

Sure. I didn't bother giving him a head since I didn't think it was important. .esp file uploaded.

#3 Updated by Kyle Cooley 3 months ago

It looks like the editor has some different defaults than the Morrowind CS. Manually set Rank to -1, Gender to blank, and PC Rank to -1, and it should work. We should probably change those defaults since having those filters unset would be a more common case. It would probably help people following Morrowind CS tutorials as well.

#4 Updated by scrawl . 3 months ago

  • Status changed from New to Closed
  • Assignee set to Kyle Cooley
  • Target version changed from openmw-cs-1.0 to openmw-0.43
  • % Done changed from 0 to 100

#5 Updated by Alexei Dobrohotov 2 months ago

  • Category set to Editor

Also available in: Atom PDF