Project

General

Profile

Bug #4025

Custom spell with copy-pasted name always sorts to top of spell list

Added by Dark Locq about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
08/16/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

If you create a custom spell and paste in text (e.g. you just created "Calm Hum+Creat, Area, Target" and are now creating a new variant, paste that name in, and change the last word to "Touch"), the newly created spell appears at the very top of the spell list, as if it is "[invisible character of some sort]Calm Hum+Creat, Area, Touch".

screenshot079.jpg View (616 KB) Dark Locq, 08/16/2017 09:36 PM

screenshot080.jpg View (705 KB) Dark Locq, 08/16/2017 09:36 PM

screenshot081.jpg View (638 KB) Dark Locq, 08/16/2017 09:39 PM

Associated revisions

Revision 67d59bea (diff)
Added by Andrei Kortunov about 1 month ago

Get only text from input fields (bug #4025)

Revision d8ab6bcd
Added by scrawl . about 1 month ago

Merge pull request #1398 from akortunov/guifixes

Get only text from input fields (bug #4025)

Revision 65d05ee1 (diff)
Added by Andrei Kortunov about 1 month ago

Get only text from clipboard (bug #4025)

History

#1 Updated by Andrei Kortunov about 1 month ago

  • Status changed from New to Confirmed
  • Operating system changed from MacOS to Other

Confirmed on Linux. Also highlighting does not work for such spells.

#2 Updated by Andrei Kortunov about 1 month ago

Generated spell will have a name such as "[#CAA560 in hex]Calm Hum+Creat, Area, Touch".
Looks like you can copy/paste all text from input field, include text color tag.
A MyGUI bug?

#3 Updated by Andrei Kortunov about 1 month ago

Ok, I found the issue:

mSpell.mName = mNameEdit->getCaption();

getCaption() returns text with formatting tags.

We should get only text instead:

mSpell.mName = mNameEdit->getOnlyText();

Also we should review other windows - any widget using EditBox can be affected by this bug (especially enchatment and alchemy widgets).

#4 Updated by Andrei Kortunov about 1 month ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

#5 Updated by Dark Locq about 1 month ago

I was going to open another bug about something similar, but maybe it's exactly the same fix (you tell me):

If you copy text from one context in the game and paste it into another (e.g. from a note you created in a map, into a savegame name) it carries styled-text info with it, and "infects" the new context with the style. It doesn't even close the styling, so that when the styled name is used again later, e.g. in 'The most recent Save Game is "[savegame name here]". Would you like to load it?', the 'Would you like to load it?' parts picks up the styling from the savegame name, too. The styling is also carried over from one savegame to another if you pick one as if to overwrite it then change the name (e.g. by adding "2" at the end, or whatever). This mis-coloring of savegame names survives game app restarts. See attached screens.

#6 Updated by Alexei Dobrohotov about 1 month ago

It's the same issue. Andrei fixed it.

#7 Updated by Alexei Dobrohotov about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF