Project

General

Profile

Bug #4004

Manis Virmaulese attacks without saying anything

Added by Demid Doroginin 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
08/06/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Manis Virmaulese, the mage who protects Mages Guild when you do first Thieves Guild quest in Ald'Ruhn, attacks you on sight, but he should first say a "Goodbye" dialogue about you being a thief.


Related issues

Related to OpenMW - Bug #3898: (mod) PositionCell in dialogue results closes dialogue window Closed 06/01/2017

History

#1 Updated by Andrei Kortunov 4 months ago

  • Status changed from New to Confirmed

Confirmed.

He starts a combat with player. It means, a game starts a dialogue, but disables a dialogue menu immediately for some reason.

A note: if you go to "Ald-Ruhn, Guild of Mages" and type in console:

Journal TG_LootAldruhnMG 10

the dialogue starts correctly.

#2 Updated by Andrei Kortunov 3 months ago

  • Related to Bug #3898: (mod) PositionCell in dialogue results closes dialogue window added

#3 Updated by Andrei Kortunov 3 months ago

A DialogueWindow::onReferenceUnavailable() function disables the dialogue.

A call of this function comes from this line.
For what reason are we disable GUI on location change? It seems this behaviour is different from vanilla (bug #3898).

#4 Updated by Andrei Kortunov 3 months ago

And just note: a player cell change caused both #4004 and #3898.

#5 Updated by Andrei Kortunov 3 months ago

This check was added to fix #290, but this check closes not only a dialogue from an old cell (#3898), but also closes a dialogue in a new cell, if it was started immediately after cell change (this bug).

How OpenMW behaves now:
1) You enter Guild of Mages
2) Scripts are executed
3) Dialogue starts by stript
4) Dialogue makes Manis Virmaulese hostile
5) onReferenceUnavailable() check disables dialogue mode, because cell was changed on this frame

#6 Updated by Andrei Kortunov 3 months ago

  • Category changed from Dialogue to GUI
  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • % Done changed from 0 to 100

#7 Updated by Alexei Dobrohotov 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF