Project

General

Profile

Bug #3997

Almalexia doesn't pace

Added by Evil Eye 2 months ago. Updated 24 days ago.

Status:
Resolved
Priority:
Normal
Category:
AI
Target version:
Start date:
08/06/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Almalexia is supposed to pace to and fro during her speech in the Dome of Sotha Sil. Instead she walks in place, moving her legs but not going anywhere.

Using the 0.42 fe8437ae10 nightly.


Related issues

Related to OpenMW - Bug #4010: AiWander: "return to the spawn position" feature does not work properly Closed 08/08/2017

History

#1 Updated by Andrei Kortunov 2 months ago

  • Status changed from New to Confirmed
  • Operating system changed from Windows to Other

Confirmed on Linux.
The only error in console is

Animation idle4 not found for almalexia_warrior

And what is source of her movement? An idle animation itself?

#2 Updated by Evil Eye 2 months ago

Looks like it isn't her script, so I guess it's her AI package. The dome has path grids she could follow.

#3 Updated by Alexei Dobrohotov about 1 month ago

  • Category set to AI

#4 Updated by Andrei Kortunov 25 days ago

Looks like position change is handled via idle animation in the NIF file.
If I remembered correctly, OpenMW should already handle this case.

#5 Updated by Andrei Kortunov 25 days ago

Strange, but if you change her AI package from AiWander to AiFollow and play animation group via console, she will pace correctly:

AiFollow 0 0 0 0
PlayGroup idle2

#6 Updated by Andrei Kortunov 25 days ago

Looks like I found the issue.
Take a look at this code. She tries to move, but AiWander forces her to stay at the spawn location.

#7 Updated by Andrei Kortunov 25 days ago

  • Related to Bug #4010: AiWander: "return to the spawn position" feature does not work properly added

#8 Updated by Alexei Dobrohotov 24 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

Andrei is on fire for the last few months.

Also available in: Atom PDF