Project

General

Profile

Bug #3978

Instant opening and closing happens when using a Controller with Menus/Containers

Added by Paul McElroy 4 months ago. Updated 7 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Input
Target version:
Start date:
07/30/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

When using a controller, pressing buttons on containers (and other menus probably) will open the container and then releasing the button will select the button at the mouses location (if the mouse is positioned over a button).

Steps to reproduce:
1- Use a controller (I used an XBox One Controller)
2- Open any container
3- Move the mouse to the "Close" button and select it
4- Open any container by pushing and releasing the button like you normally would
5- The container should open and then close immediately

Associated revisions

Revision 09e93319 (diff)
Added by scrawl . about 2 months ago

Restrict the 'fake mouse movement' workaround to where it's actually required (Fixes #3978)

History

#1 Updated by Andrei Kortunov 4 months ago

I used an XBox One Controller

A bluetooth one? Did you encountered #3964?

#2 Updated by scrawl . 4 months ago

  • Status changed from New to Confirmed

This happens with all controllers.

#3 Updated by scrawl . 4 months ago

  • Operating system changed from Windows to Other

#4 Updated by Will Herrmann 4 months ago

  • Target version set to openmw-0.43

#5 Updated by scrawl . 3 months ago

  • Category set to Input

#6 Updated by Will Herrmann 2 months ago

Does this have any relation to #3123 (Dialogue box is automatically closed using gamepad)?

#7 Updated by Paul McElroy 2 months ago

Looks like the same bug. When using a game pad, the program remembers the last placement of the cursor and seems to "click" after the button used to open the gui is released instead of only operating on button pushed events.

#8 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to scrawl .
  • % Done changed from 0 to 100

#9 Updated by scrawl . about 2 months ago

Admittedly I've only tested this fix with mouse buttons (Activate bound to Left mouse was showing the same issue). Anyone can test if controllers are really fixed?

#10 Updated by scrawl . about 2 months ago

  • Status changed from Resolved to Closed

#11 Updated by Paul McElroy 7 days ago

A similar problem happens using a game pad in the char gen menu and when selecting dialogue options. Might happen with other menu options scattered throughout the GUI. Should I make a new issue?

#12 Updated by scrawl . 7 days ago

Yes please, preferably with more info than above. Does it also happen without a controller if 'Activate' is bound to Left click?

Also available in: Atom PDF