Project

General

Profile

Bug #3974

Journal page turning doesn't produce sounds

Added by Roland Hist 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Low
Category:
Sound/Other Media
Target version:
Start date:
07/29/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Minor

Description

There is no sound when scrolling through your journal. There's also no sound when closing it. Only when you open it the proper sound is played.

All other scrolls and books play proper sound during all of the above, however.

Associated revisions

Revision 99b5f21a (diff)
Added by Andrei Kortunov 4 months ago

Add missing journal sounds (bug #3974)

Revision 4b51fd23
Added by scrawl . 4 months ago

Merge pull request #1356 from akortunov/guifixes

Add missing journal sounds (bug #3974)

History

#1 Updated by Andrei Kortunov 4 months ago

Which OpenMW version are you using? I am pretty sure: I added journal closing sound a several months ago.

But about missing scrolling sounds you are right.

#2 Updated by Roland Hist 4 months ago

Hey there, I'm using the latest version, 0.41. My OS is Ubuntu 17.04.

Since I have a pretty heavy loudout for my normal playthrough, I had tested it without mods enabled (except Tribunal, Bloodmoon and TR 16.12) before submitting this bug here :)
but no closing or scrolling sound.

How is the journal sound handled, anyway? I'm no good at programming or scripting, but it surprised me that the journal and all other scrolls and books in the game are distinct.

#3 Updated by Alexei Dobrohotov 4 months ago

  • Subject changed from Journal Sound Effects to Journal page turning doesn't produce sounds
  • Status changed from New to Resolved
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100
  • Operating system changed from Linux to Other

#4 Updated by Will Herrmann 4 months ago

Confirmed on macOS with the 2017-07-29 nightly build.

#5 Updated by Roland Hist 4 months ago

Andrei Kortunov wrote:

Which OpenMW version are you using? I am pretty sure: I added journal closing sound a several months ago.

But about missing scrolling sounds you are right.

Just a little update; the closing sound is indeed there, but only if you mouse-click on "Close".
If you use the Journal key-bind to close it, no sound is played.

#6 Updated by Alexei Dobrohotov 4 months ago

  • Status changed from Resolved to Closed

#7 Updated by Alexei Dobrohotov 4 months ago

  • Assignee set to Andrei Kortunov

Also available in: Atom PDF