Project

General

Profile

Bug #3963

When on edge of being burdened the condition doesn't lower as you run.

Added by Marcin Kolenda about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
07/22/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

I'm carrying 375/375 weight of items. When I run the condition doesn't lower so i can run forever. But when I drop some items the condition is working as it should.
There must be sneaky "<" operator instead of "<=" in some conditions.

Associated revisions

Revision 325ea105 (diff)
Added by Andrei Kortunov about 2 months ago

Fixed encumberance check (bug #3963)

Revision d3be4769
Added by scrawl . about 2 months ago

Merge pull request #1347 from akortunov/encumberancefix

Fixed encumberance check (bug #3963)

History

#1 Updated by Plutonic Overkill about 2 months ago

Just a guess, but it looks like it could be because of this line?

#2 Updated by Andrei Kortunov about 2 months ago

Just a guess

Your guess is right. There should be "<= 1".

#3 Updated by Will Herrmann about 2 months ago

Should this issue be marked as being for 0.42.0? I thought that that version had been completed months ago?

#4 Updated by Plutonic Overkill about 2 months ago

Are floating-point equalities really a good idea? I'm not familiar with the code, but I would think that it would be better to insert a check to see if the player is actually moving, rather than checking their encumbrance.

#5 Updated by Alexei Dobrohotov about 2 months ago

  • Target version deleted (openmw-0.42)

#6 Updated by Andrei Kortunov about 2 months ago

Are floating-point equalities really a good idea?

We are already use the same approach to check if a player is overburdened in inputmanagerimp.cpp

#7 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from New to Resolved
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

#8 Updated by Alexei Dobrohotov about 2 months ago

  • Status changed from Resolved to Closed

#9 Updated by Alexei Dobrohotov about 2 months ago

  • Assignee set to Andrei Kortunov

Also available in: Atom PDF