Project

General

Profile

Bug #3955

Player's avatar rendering issues

Added by Andrei Kortunov 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Rendering
Target version:
Start date:
07/13/2017
% Done:

0%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

On the attached screenshot you can see graphical glitches on a player's avatar in inventory. Player mesh itself is rendered correctly. A bodypart scaling issue?
Tested with Better Bodies + Better Clothes and with Robert's bodies.

Mororwind engine does not have this bug. Also Morrowind GUI is affected by antialiasing, so player's avatar is antialiased too.

Avatar.jpg View (153 KB) Andrei Kortunov, 07/13/2017 01:37 PM

DB_Avatar.jpg View (108 KB) Andrei Kortunov, 07/13/2017 01:58 PM

Associated revisions

Revision 9bc24ab6 (diff)
Added by scrawl . 2 months ago

Fix character preview zNear/zFar not being autocomputed as intended (Bug #3955)

History

#1 Updated by Andrei Kortunov 2 months ago

A screenshot with Better bodies and DB armor replacer. Again, in-game player model is rendered fine.

#2 Updated by scrawl . 2 months ago

The only thing I could think of that is special about avatar renderings is the transparency handling, set up here:

    void CharacterPreview::setBlendMode()
    {
        SetUpBlendVisitor visitor;
        mNode->accept(visitor);
    }

Does it render correctly with that function commented out?

#3 Updated by scrawl . 2 months ago

Also Morrowind GUI is affected by antialiasing, so player's avatar is antialiased too.

Is it really? As far as I know, the whole GUI is just blurry because it's rendered at a sub-pixel offset. MCP includes a fix to un-blur it.

We can do antialiasing by increasing the resolution of the texture, or we can use FBO multisampling (which isn't available on all devices, and it seems like OSG doesn't have a nice way to query for support or fall back to a lower value).

#4 Updated by Andrei Kortunov 2 months ago

Does it render correctly with that function commented out?

No difference for me.

#5 Updated by Andrei Kortunov 2 months ago

Can it be a some kind of rounding error when an engine scales bodyparts?

#6 Updated by scrawl . 2 months ago

  • Status changed from New to Closed

The preview had an issue with zNear/zFar values not being set correctly that resulted in less depth precision than in the main game. Fixed in 9bc24ab629992959323340bb325024ae68a7635a .

Still, it seems there are issues that should be fixed in the mod with the vertices not matching up exactly.

#7 Updated by Alexei Dobrohotov about 2 months ago

  • Assignee set to scrawl .

#8 Updated by Alexei Dobrohotov about 1 month ago

  • Target version set to openmw-0.43

Also available in: Atom PDF