Project

General

Profile

Bug #3908

[Wizard] User gets stuck if they cancel out of installing from a CD

Added by Will Herrmann 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Launcher
Target version:
Start date:
06/07/2017
% Done:

0%

Reproducibility:
Always
Operating system:
MacOS
Severity:
Normal

Description

There is an issue with canceling out of installing from a CD that leaves the user with the apps open, but no windows open to interact with anything. To reproduce:

  1. Launch OpenMW
  2. Run the Installation Wizard without having a retail CD in the drive
  3. Click "Next" on each screen (noting that the "Select Installation Method" screen had install from a CD selected by default)
  4. Once you reach the final screen, click the "Install" button
  5. A file chooser will appear. Click "Cancel"
  6. The next screen will say that "The installation was aborted by the user". Click "Next"
  7. Click "Finish"

The user is stuck with nothing to do. No windows appear and the only thing to do is force-quit.

On macOS, two items are in the dock at this point, both with the name "OpenMW". The first one to appear is the one that appeared when OpenMW was first launched. Right-clicking on it shows a "Quit" menu item, but it doesn't work due to #2862. The second one appeared when the Installation Wizard was launched. Right-clicking on it shows an "Application Not Responding" message and a "Force Quit" menu item. If you choose "Force Quit", the main app shows a dialog saying that the Wizard errored out. Wizard.log shows the following unhelpful text:

Started OpenMW Wizard on Tue Jun 6 22:17:47 2017
Error: The installation was aborted by the user

This has only been tested on macOS 10.11 (El Capitan). It would be useful to test on other platforms too.

History

#1 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from New to Resolved
  • Target version set to openmw-0.43

#2 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF