Project

General

Profile

Bug #3879

Dialogue option: Go to jail, persists beyond quickload

Added by Hla Mas 6 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
Start date:
05/21/2017
% Done:

0%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

1. Commit a crime within view of a guard.
2. Get caught.
3. Choose "Go to jail".
4. Don't click "Goodbye".
5. Quickload.
6. After the game is loaded, you will be teleported to serve time in the jail in the area after the quickload.

It's caused by an unhandled case of the feature: "you can quickload the game from the dialogue window", which wasn't possible in vanilla Morrowind.

History

#1 Updated by Andrei Kortunov 6 months ago

Confirmed.
Look at https://github.com/OpenMW/openmw/blob/master/apps/openmw/mwworld/worldimp.cpp#L1615
It seems mGoToJail is still true after reload.

We can set mGoToJail = false after reload or can forbid quickload when game is paused.

#2 Updated by Alexei Dobrohotov 6 months ago

  • Status changed from New to Resolved

#3 Updated by Alexei Dobrohotov 6 months ago

  • Status changed from Resolved to Closed

#4 Updated by Alexei Dobrohotov 4 months ago

  • Assignee set to Andrei Kortunov

#5 Updated by Alexei Dobrohotov 4 months ago

  • Assignee deleted (Andrei Kortunov)

Also available in: Atom PDF