Project

General

Profile

Bug #3864

Crash when exiting to Khartag point from Ilunibi

Added by Ole Vegard Moland 4 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
05/11/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Critical

Description

Environment
Vanilla Morrowind, retail copy, no expansion packs. Run on a Linux ( Manjaro ) desktop PC with a dedicated graphics card

Reproduce
Exit Ilunibi

openmwcrash.zip (25.1 KB) Ole Vegard Moland, 05/11/2017 10:12 PM

Crash.omwsave (7.55 MB) Ole Vegard Moland, 05/12/2017 06:47 PM

Associated revisions

Revision d2428627 (diff)
Added by Miroslav Remák about 2 months ago

Prevent respawned references from being added to the scene twice in certain cases (Fixes #3864)

History

#1 Updated by Miroslav Remák 4 months ago

Cannot reproduce. Please attach your savegame.

#2 Updated by Ole Vegard Moland 4 months ago

Added the save. Game crashes right after exiting

#3 Updated by Andrei Kortunov 4 months ago

I can confirm this crash. Note: a crash log points to MWWorld::InventoryStore::fireEquipmentChangedEvent(). I got this crash only at night. When I tried to wait until the morning, I managed to leave the cave without crash.

#4 Updated by Miroslav Remák 4 months ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to High
  • Severity changed from Normal to Critical

#5 Updated by R. D. 4 months ago

I can also confirm, but the crash doesn't happen always. Usually I can exit the cave without a crash.

By the way, possibly related is that there is something strange with the "hlaalu guard_outside" guard nearby. Leave the cave and go south to Gnaar Mok and you'll find him seemingly walking in place. Have him attack you or anyone else, and you'll hear his footsteps moving around and he'll be able to attack his target even though he looks like he is still stuck in place.

#6 Updated by Ole Vegard Moland 4 months ago

Yeah, I was suddenly able to exit and continue the game normally during day. I haven't seen any crashes after this.

#7 Updated by R. D. 4 months ago

Even without waiting until day, I usually don't have a crash when I exit the cave from that save. But the crash log does suggest the problem has something to do with NPCs and torches.

#8 Updated by Miroslav Remák 4 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to Miroslav Remák
  • Target version set to openmw-0.43

#9 Updated by Alexei Dobrohotov 4 months ago

  • Category set to 8
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • Operating system changed from Linux to Other

#10 Updated by Alexei Dobrohotov 4 months ago

  • Category deleted (8)

#11 Updated by Miroslav Remák 3 months ago

  • Status changed from Resolved to Confirmed
  • Assignee deleted (Miroslav Remák)

#12 Updated by Miroslav Remák 3 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to Miroslav Remák

#13 Updated by Miroslav Remák about 2 months ago

  • Status changed from In Progress to Confirmed
  • Assignee deleted (Miroslav Remák)
  • % Done changed from 100 to 0

#14 Updated by Roman Siromakha about 2 months ago

Here is description of the problem and solution https://github.com/OpenMW/openmw/pull/1360

#15 Updated by Will Herrmann about 2 months ago

If you want to be able to assign yourself to this bug, we've got a thread going here.

#16 Updated by Miroslav Remák about 2 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to Miroslav Remák

#17 Updated by Miroslav Remák about 2 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF