Project

General

Profile

Bug #3863

Can be forced to not resist arrest if you cast Calm Humanoid on aggroed death warrant guards

Added by Alexander Nadeau 7 months ago. Updated 4 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
AI
Target version:
Start date:
05/08/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

- Do something a guard doesn't like
- Let the guard talk to you
- Resist arrest
- Cast Calm Humanoid on them
- If you're within talking range, you are now stuck in an endless loop of conversation boxes, until you select something other than "Resist Arrest".

Associated revisions

Revision e0c54b3f (diff)
Added by R. D. 8 days ago

Stop guards trying to arrest player when calm

(Fixes #3863)

History

#1 Updated by Alexander Nadeau 7 months ago

This happened with a follower. I forgot about that. I'll see if I can reproduce it on a nightly build with a commanded guard.

#2 Updated by Alexander Nadeau 7 months ago

Yeah, I can't reproduce this with normal guards. The NPC it happened with originally was the first follower that the Bloodmoon quest gives you when you go to the smuggler's cave.

#3 Updated by R. D. 7 months ago

One thing I noticed from testing a while ago is that a guard follower in OpenMW still has the arrest behavior, while in the original game they don't. This could be related.

#4 Updated by Pseudo Nonymous 5 months ago

I can confirm I can reproduce this issue in OpenMW 0.41.0 running on Linux.
I killed a bunch of people in Balmora, ran up to a random guard, resisted arrest, then cast calm humanoid.

Every time I click "resist arrest" the game advances by a single time step before the "you are under arrest" dialog reappears.

#5 Updated by Andrei Kortunov 4 months ago

Strange. I can not reproduce the endless loop with upstream code.
When I cast a Calm Humanoid on a guard-follower, he will draw/holster his weapon several times (an AI packages priority bug?).

guard follower in OpenMW still has the arrest behavior

Note: only player's followers guards do not have a Pursue behaviour.

Also a follower-guard will not report about your crimes in OpenMW, but still will try to arrest you, if there are another reporters.

#6 Updated by Andrei Kortunov 4 months ago

Please, try to reproduce this bug with latest master. Followers-guards do not have a Pursue behaviour now.

#7 Updated by Andrei Kortunov 4 months ago

  • Status changed from New to Feedback needed

#8 Updated by Alexei Dobrohotov 3 months ago

Cannot reproduce either.

#9 Updated by Randy Davin about 2 months ago

Alexei Dobrohotov wrote:

Cannot reproduce either.

Same here.

#10 Updated by Plutonic Overkill 9 days ago

I managed to reproduce this with the final 0.43 release candidate by getting a death warrant and then casting Calm Humanoid on some Ordinators. It's even worse here, as the only dialogue option is 'Goodbye', so there is no way to get out of this loop without somehow moving away from them, and you cannot access the menu. It also might have had something to do with the fact that I used Levitate to fly above their heads, causing them to start fleeing. I can attach a savegame if needed.

#11 Updated by Plutonic Overkill 8 days ago

On further testing, I found that I can reproduce this every time in 0.43 with any type of guard simply by killing enough guards to raise my bounty above 5000 and then casting Calm Humanoid.

#12 Updated by Andrei Kortunov 8 days ago

  • Category set to AI
  • Status changed from Feedback needed to Confirmed
  • Operating system changed from Windows to Other

#13 Updated by R. D. 8 days ago

I can also confirm.

I tested using guards in Seyda Neen, setting player bounty to 5000 and casting Calm Humanoid on a guard after they've entered combat with player.

In original Morrowind the guard that was cast upon stops fighting and resumes wandering while the spell is active. Trying to talk to him though will show "This character is in combat," though. After the spell wears off he resumes attacking the player.

#14 Updated by R. D. 8 days ago

After the spell wears off he resumes attacking the player.

But when he does this, he doesn't open the dialogue again, he just starts attacking.

#15 Updated by R. D. 8 days ago

"This character is in combat" behavior doesn't happen if you cast Calm Humanoid on other NPCs. You can talk to them after casting the spell. I tested with both a non-hostile NPC that I forced into combat with "startCombat player" and a hostile NPC that attacked me naturally when I approached them.

#16 Updated by R. D. 8 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to R. D.

#17 Updated by Alexei Dobrohotov 7 days ago

  • Subject changed from Can be forced to not resist arrest if you cast Calm Humanoid on aggroed guards to Can be forced to not resist arrest if you cast Calm Humanoid on aggroed death warrant guards
  • Target version set to openmw-0.44
  • Reproducibility changed from Have not tried to Always

#18 Updated by R. D. 4 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF